Download

My Playable Character is Missing

I have a playable character with animation and follow camera. I have Game Mode Blueprint that I set as my Game Override that uses the character as the default pawn. When I play the game to test it in the editor the player doesn’t appear. However, if I choose Possess in the debug or Game Mode Editor the character appears and plays like I expect it to. What do I need to set in order that I don’t have to Possess the character this way? Is there some setting I am missing?

Everything turns out to be okay with my character, blueprints, etc. I stumbled upon the fix by just randomly looking at the play button settings in the editor. Mine was set to simulate. I set it back to viewport and everything seems to work. So where did it go when I said simulate instead of play in viewport?

Found this in the docs, hope it helps c:
Using the Simulate button begins a Simulate In Editor session in the currently active viewport. While simulating, gameplay begins, including the execution of Blueprints and C++ code that do not rely on a player’s interaction with the game. While simulating, you have full access to the Editor’s tools, so you can modify the scene and its contents, or even place new Actors. You can also select and inspect Pawns controlled by AI right as they are performing actions, and quickly debug and tweak gameplay behaviors. However, because you are not using a PlayerController while simulating, you cannot enter game controls. You can save certain changes made in a Simulate In Editor session using Keep Simulation Changes.
[In-Editor Testing (Play & Simulate) | Unreal Engine Documentation](docs page)

That makes some sense. I had been doing a lot of testing with AI characters before I switched back to a Playable Character. Maybe I turned on the Simulate option.

I went back and forth from simulate to viewport and I still can’t get my character to reappear. Which means I can’t tweak his followcamera either. This is ■■■■■■■ me off.

This is a recurrent issue one thing is to double check that you don´t have any game mode selected in World Setting / Game Mode details.
It is used to set a game mode per map.