My performance is awful on a new PC. Why?

I built a new pc using a gtx 980 ti, an Intel i7-6700K, an Asus Maximus VIII Hero mobo, and a clean Windows 10 install. I have 32GB of DDR4 ram. Performance in UE4 is terrible, and UE4 is the only application I have tried that did not have stellar performance. I have more than a full second of lag on all my mouse movements and clicks when using the editor. Performance gets worse at a higher rate with more windows than with more tabs. UE4 is essentially unusable like this. Currently I am using the GeForce 358.78 driver. I tried several driver versions with no differences.

CPU usage is around 16% and memory around 13%. The CPU usage seems a bit high, but it isn’t maxing out any cores. Without UE4 open CPU usage is typically around 3%.

I’ve been dealing with this for about two weeks now, and I haven’t found anything that helps.

Any assistance is much appreciated.


Changing scalability to Low gives enough of a boost to make the editor usable, but I shouldn’t be having trouble on this hardware.

I also want to mention, I have 3 monitors, an Oculus Rift DK2, and a Razer Deathstalker keyboard with Switchblade UI thing. One monitor is hdmi, one is display port to an hmdi adapter, one is display port to vga adapter, and the DK2 is using a display port to hdmi adapter.


My PC just updated to Nvidia driver 358.87 and wow, its way worse. Even having scalability on low can’t help me get less than a second of mouse lag and more than 10 fps play in editor. Rolling back the driver doesn’t fully restore the performance I had.

I tried with less monitors and didn’t notice a difference. I am currently using the same monitors I used on my old Win 7 PC and it had no problems.

Additionally, I have noticed that translucent materials look very flat, in that they seem to have no lighting. Even if you input 1 into the opacity, they still look very translucent as well.


Had a crash that seems to be related to these issues.

Hey BlackRang666,

Could you check out our Software Conflicts Wiki Page to see if you’re using any of the software listed there? There are a few that are specific to Win10.


Thanks for the link. None of my searches turned up that page. The only two that could actually be installed on my system are Intel integrated graphics drivers and Windows 10 notifications. I have integrated graphics disabled in the bios and I don’t have any notifications in the list as I have kept notifications disabled.

Try going to Settings at the top next to Blueprints

Then under Scalability go to Engine Scalability Settings & change quality to low

After, below Engine Scalability Settings change Material Quality Level to low and that should increase program performance without hindering visuals too much. It will definitely speed things up, especially dragging large files onto the main map.

You could also change Preview Rendering Level to something of less quality, like Shader Model 4 or Mobile/HTML 5

I would also recommend in the NVIDIA Control Panel click Manage 3D Settings, add Epic Games Launcher as a program to customize, then in the drop down menu right below select the graphics processor: High Performance NVIDIA processor

Right click the Epic Games Launcher wherever it is located, and run as administrator.

Good suggestion. Changing scalability to Low definitely gives enough of a performance boost to compensate and make the editor usable. I wouldn’t have thought that scalability settings would have such an impact on UI stuff. Still, I shouldn’t be having issues like this on this hardware. I just upgraded from a seven year old pc that was having no issues like this.

Can you pass along your dxdiag info? I’d like to see if we can set up a machine close to these specs and try it out. I don’t want to speculate too much, but something tells me there could be some weird compatibility issues (980+Win10 might not be behaving).

Have you tried disconnecting some of the display devices to see if it increases performance? Specifically try with just 2 monitors. Are they 1080p or 4k?

link text

Here is the DXDiag.

Two of the monitors are from Asus and 1080p and one is less, its a Yiynova MSP19u. I’ll try with less monitors, and post back if I can notice any differences.

The newer versions of the Nvidia Drivers are usually for gaming and have issues with software like this…Give 353.62 which windows installs by default a shot. I was using 358.xx on a Core 2 Duo with 4GB of Ram and GT 730 on Windows 10 pro and it was not very usable…I removed and let Windows install the latest Win10 drivers and it was workable at a notch lower than Epic.

Obviously that machine was dragging, but my main machine had the same issue. Since I don’t game I use the latest stable Win10 drivers…Not the “game ready” those are basically beta drivers with fixes for whatever game they list…

I cannot use such an old version because it is not supported by the latest Oculus Runtime.

Hello BlackRang666,

Would you be willing to try rolling back your drivers simply to see if that could be where the issue is? It would be best to narrow the problem down as much as possible and ruling out driver issues would be a big step forward.

I did an express install of 353.62 and performance seems a bit worse. Even with everything on low I’ve got lag in everything, even the viewport. Before it was just noticeable on mousing over buttons, typing text, etc.

Currently, we don’t have a Nvidia 980 ti in-house to test the editor with, but we are working on getting one so that we can test this issue for you and fix it if we are able to reproduce the problem. I’ll be sure to update you here when progress is made or if we have any more questions to ask you.

Any news? I’ve been noticing I get crashes pretty often on 4.10

We currently have a on order to be used to test this issue and many others. Until then we’ll but unable to test these issues and find the root problem.

I’d like to chime in and say that I have been having the same issues since I did a clean install of Win10 on my Skylake setup. I am running a Core i5-6600k, 16GB of ram and dual 980ti. I was having the issue with a single 980 (non-TI) as well though, before I recently upgraded to an SLI setup.

I am seeing 4-10 fps when mousing over the UI, maxed out 120 fps when I press play.DXDiag

Sorry you are having problems too, but is comforting to know I’m not the only one. It sounds like we have Win10, , and a form of 980 in common.

I’m not so sure the Graphics card is really the issue. I have seen plenty of people reporting that UE works great on Win 10 so I am guessing they don’t have Skylake. Have you tried any BIOS updates? I think that will be my next attempt. Stay strong! I have faith in Epic lol

Updated my MSI Z170A Gaming M7 motherboard from BIOS version 1.2 to 1.8 last night. No change in performance.

We got a and I tried to reproduce the same lag issues you are receiving to no avail. It may be related to the and that is the only other thing I can think of. I’ll be investigating further and let you know if I find out more.

Thanks for attempting that . At least you have a new 980Ti on the bench to “test” ;D

Did you by chance get to look at my copy of dxdiag I posted? I was just going over it again and noticed some UE4 specific entries at the bottom of the file. Not sure if those are “normal” or helpful at all. I may try to setup a dual boot with Win7 on this machine to try and further narrow down the issue.