My PC freezes on building lights

Baking shadows on 2014x2014 height-map based landscape with few trees.

Now im aware of magnitude of work while baking shadows on landscapes but this is somewhat ridiculous, im having my computer totaly freeze for 2hours now while building is still at 0%
i accidentaly clicked folders open on windows and since then it’s been completly unresposive.

there is no background software running other than chrome and now the folder window

My computer specs are i5-2500 3,3ghz, 18GB of ram and GTX970 running on win8 - 64bit

it’s not the most powerfull setup of the world but c’mooon it should be able to bake some shadows.

Is there a way to make this work or should i just go back and forget this engine…

EDIT: i’d give more detailed info about my level but im not feeling like unplugging my PC after 3h of waiting
and it’s still not responding to anything

I get this when building a large map. It might not be broken even though the clock freezes as well as the mouse.

My advise be patient and wait a good hour for it to build, the PC will gradually come back to life during hte build process.

Long lightmass build times are related to lightmap size, so make sure you have set all those to sensible sizes, and use the lighting info - lighting static mesh info (under build) to see how big the light maps are you have allocated and it all adds up to.

FYI, I have levels of around 4.5 Gig of lightmap textures and they currently take about 3 hours !!!

W Jones

Hi Clonez,

There are a few things that could be causing this that could lead to longer build times, even being seemingly being stuck at 0%.

Some things to consider that would be a good place to start trying to track down issues:

  • Foliage lightmap resolution size for static meshes. Uses default static mesh LM resolution right now (will default to lower value in 4.8) The lightmap resolution should be set to something like 4 or 8 for instanced meshes using the foliage tool.
  • Lightmap resolution of the landscape
  • Make sure your scene is using a Lightmass importance volume. Doesn’t work as well over very large areas.
  • Number of instances in a scene can affect build times
  • Hardware limitations (doesn’t appear to be an issue with your setup from what I see. More directed at Mid to Lower range hardware)
  • Build Lighting Quality (Preview > Production)

Another thing you can do is open Swarm Agent (Small orange and black logo in your task manager bar) This will have three tabs. The log on the left will tell you what is going on, the swarm status will show you the lights building going on, and settings has a few thing in there as well for setting up build farms.

Eric and I are working on getting some troubleshooting for lightmass up on our Lighting Troubleshooting and Tips guide: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

We’ve not had a good chunk of time to get this in a more final stat just yet, but it’s coming. This should help with some lightmass building issues.

Building lighting for large worlds can be very heavy process and is the reason that most open or large worlds use dynamic lighting instead.

Give some of the listed suggestions a try and see if this helps improve your build times.

Let me know how it goes as well. :slight_smile: