Download

My mod wont be installed on server??

Hi

I really need some help here
When I first made the mod I added it to my 2 servers, one of them succeded… The other didnt
Now about a month later I wiped a server, but the mod wont be installed… I tried everything

  • Completly Re-installed my server
  • Only add my own mod
  • Upload mod-folder from my own steam-mod folder
  • Validate server files
    Nothing is working

It is still running fine onn one server, since beginning. But fear for the day that need new mod-pack

Is there something I can check for in the devkit, Maby something in the mod is broken for install??
Its my first mod I make

Does your mod work in single player game mode?

I Just tried … Crashed with crash-log, 2 times same log

What does your mod add an inventory to? Make sure that the actors in your mod have only one inventory component.

Its this mod
https://steamcommunity.com/sharedfil…?id=1880662415

Severel inventorys
Not really sure what you mean :slight_smile:

I mean that, in your structure’s component tab, make sure there is only one inventory component. More than one inventory in an actor usually causes crashes.

99% sure there is only one, but ill check
Could that be the reason for the posts main issue… Not being able to install the mod??

I found that one structure had same inventory as another
Other than that all had the right one, and only one
Gonna see if I can get it to cook and upload update
Then hopefully install on my server :slight_smile:

Well… 2 week’s after, Im still trying to figure out what is wrong
I have gone through pretty much every file in the mod

Still same problem, it wont cook … Crashes devkit completly. Sometimes even my PC crash

Ive searched the web for solutions, none that has helped so far

Does having “childs” of resources cause problems??
Ex. I have a custom chembench with “Child-bp” of the crafting resources

I have it that way in many of my structures

Otherwise im completly blank by now, and etremly frustrated, not being able to use my many hours work on my own servers

It’s not easy to determine if the child-bp’s would be causing the issues without more information about what you are using these bp’s for. Have you tried joining the ARK modding Discord? There are many more users there available to help.