My mod coocked, but does not really work...

Hello all

I’ve a problem with my mod : when i test in ADK, all is ok, but after cook, not really…

In my mod-list for solo game, the first line have no name ? juste empty… But i can select it…

After loading, in game, i have no new engram in my list, but i can give my item with admin command…

I have a new smithy in my mod, i can “give” it in my inventory, but impossible to place it, i dont have the green model for place it…

I’ve already check the tutorial for “Cook a mod”, and no solution…

If anybody have solution for resolve the problem ?

You have to add your engrams in your ‘’ PrimalGameData_BP ‘’ you have to add it where it says ‘’ additional Engram Blueprint Classes ‘’

Thank you for your reply :slight_smile:

I had already done it, my blueprint are present in ADK, but not in the game :confused:

Make sure you have your PrimalGameData_BP in the root of the mod,
Osea in the folder of your mod, because that is the most important !!

Yes, all the files “Generic Mod”, which i renamed, are in the root of my mod folder.

For the renamed, i replaced the terms “Generic Mod” by the name of my mod, as on the tutorial.

No one had the same problem ?

It sounds like your PrimalGameData isn’t set up properly and/or the cooking process isn’t correct. What tutorial are you using?
As for not being able to place your smithy, do you have it set up under “Additional structures to place” in the PrimalGameData?

Yes, but not works :’(

(i have read in a french tutorial, i’m french ^^)

I have this, in ADK:
c7dfcb9a03a8bdcc053e6962842e08e00275759a.png

I dont know if is normal but, i also noticed that : my mod files include a folder “Maps” with a file “TestMapArea.umap” ???

Makes me crazy, i have a mod that is finished, but no way to play with :’(

I don’t think Additional Structure Engrams actually works, maybe someone who’s more up to date with dev kit changes could chime in but I know it was bugged before. Also, have you set up your mods level file(orange colored file) with your mods PrimalGameData_BP in the Primal Game Data Override section and set the Gamemode Override to “None”?

In the World Settings of my level mod, i have my PrimalGameData_BP in the Primal Game Data Override, and i have my TestGameMod_ for Gamemode Override…

i must delete this ?

963b80d7ed7e9044a05ec447d5fb6ad7954a8587.png

If your PrimalGameData_Child has information in the “Mod Name” and “Mod Description” lines and it isn’t appearing in game, that means your PrimalGameData is not loading properly. I’ve noticed that after certain major releases, mods stop working because the PrimalGameData bugs out (mine have done this). The only way I’ve found to “fix” it, is to go into PrimalEarth, locate PrimalGameData, and drag it to your mod folder and create a new child, then readd everything. I’ve noticed that mods that break new engrams have to do this.

I have try to replace my PrimalGameData with a copy of the PrimalGameData of the PrimalEarth folder, and same problems :’(

For my mod, i want add a new crafting table (based on anvil_bench), for craft a new type of narcotic ressource, and this ressource can be used for craft 3 news narcotics items : arrow, dart, and shockdark, more powerfull than classic items. And if i use the give command, for my custom smithy, impossible to place (no visual green model) and for my ammo, i can use them… But always no engram in my list…

If anyone want check, for a solution, i can upload my mod files ?

Is it a copy, or a child? It’s very important that you Create Child, not Create Copy.

My level mod (in orange) and my GameMode are a copy

My PrimalGameData is a child of the PrimalGameData, in the PrimalEarth folder.

I’ve rename PrimalGameData_Child and replaced “Child” by my mod name.

But again same problems :’(

I’m sorry to bother you with this, again thank you for your help !

Remove the GameMode, it isn’t required and is likely causing you issues. GameMode also needs to be a child, but if you’re not editing anything inside of it, do not use it. Open up PrimalGameData and return your GameMode to the original TestGameMode.

Same results :’(

I have upload my original mod, and a small version, i use it for test, if any want use it ?

Small Version : http://ul.to/cqs6gkvy

Complete Version : http://ul.to/s2d0ugbj

It is a copy of my mod, present in the folder : “Epic Games\ARKDevKit\Projects\ShooterGame\Content\Mods”

I dont know if this files can be used by another or if is just for my PC ?

I can’t see your test version because the file host only allows a download every 180 minutes, but I looked at your Complete version and your Level file and PrimalGameData_BP had a couple of issues. In your level file there’s a section named “force load map name” yours says “The Island”, it should be blank so it can be used on other maps. Further down, there is a part called “Gamemode Override”, that should be set to “none” since you aren’t using a game mode. You can also delete the TestGameMode file from your mod as it won’t be needed.

In your PrimalGameData_BP, the Mod Name and Mod Description are blank so that’s why you aren’t seeing them in your mod list. You have your NarcoBench under “additional structure engrams”, it needs to be under “additional structures to place”(I saw you posted a pic of it correctly, but it’s not correct in your complete version link). Also under App IDItems and Default Game Mode, click the yellow arrow and reset those.

I’ve done all of that and reuploaded it, try this and see if it works: http://www.filedropper.com/narcotic

Hello and thank you :slight_smile:

Actually, I only touched the mod test, I thought to modify the full mod only after having managed to run the small test mod ^^

I download your file and i try :slight_smile:

I have try with your files, the mod has no name, and in game, i can’t see the engrams and i can’t use the give command.

It works on your computer ?

Forget all of that. I was able to download your test version today and it’s correct. I actually cooked and tested it on my end and it’s working fine in single player. I was able to see and learn your engrams, craft and place your smithy so your cooking process must be incorrect.
Double click your level file(orange file) and let it load up until you get the black map, on the right hand side double check in the world settings to make sure it’s all correct for your mod(it should be). Now select Steam Upload from the top of the dev kit, a window will pop up and on the left hand side select your mod (NarcoPlus). Now add a preview image(png file type), fill out the Title (this is the name that actually shows in the single player mod list), fill out the description, set your visibility and put something into change notes. Now scroll to the top and select “Cook Game Mod”. Give that a few minutes to finish and a window should pop up saying it’s finished. Now sign out of Steam and from the mod cooking window select “Upload”, a window will pop up that you input your Steam info into and choose accept. Another window will pop up with the uploading process and it should complete in a few minutes. Depending on your Steamguard settings you may need to disable Steamguard or input a security code into that window.
http://imgur.com/a/VNp7L