My Media Player Failed to Open

My Media texture are not wo

rking … Media file failed to load

Did you enable to “Media Player” plugin’s?

Yes I Enabled that , eve though that same error pops up . I Even Reinstall the UE 4 but that error not fix it showed the same on the Screenshot’s .

Blackforcedragon I don’t Understand why it doesn’t work as i do them some of my previous projects.

What folder is the movie’s in?

Yess the folder was Downloads in C drive but few days ago C Drive was formatted … Dose it the reason to not working … of media player So that’s why my files not working …



You need a folder called “Movies” in unreal engine “Content” folder

“Content/Movies” and add you video in that folder. If the wider don’t play for you, then use hand break to encode the video so Unreal Engine 4 can read it.

Tell me if that helped you or you need or if you need more help.

No Its not working yet … I really dont understand what happen…

Add this an “Open Source” node and a “Media Player” node to a “Begin Play” in the Level BluePrint.

Tell me if this did help you or if you need more help.

Yes i also do that but cant work my , File source path marks error and that media dosent play

I think i need to format , or i dont use the media player

is your movie in the project “Movies” folder?


Yess But not Worked , Actually in any project or New projects that media player dose-not work and have the same Error … May b it some Log file Error or may be i need to Format again or i dont Know … the problem remain same even if i install new or Different version …

here is a link to my project, you need to unzip it and open the project.
You need to go in the folders to find the video.

it runs in version 4.22

and here is a video from youtube


I also was froced to use Handbreak to encode my video so Unreal can read it.

Do you need more help?

Thank you … Sir
the Same Media Player working on Other System… But not on Mine …
Sir one thing i fund in my system that Windows media player is not installed … But other player like VLC & GOM are installed … Did it effects on that … I think thats may the Problem But not Sure … Please Give me a suggestion on that …

if That’s the reason , then i will format my system again for fresh install…

You need to re-encode the video with handbrake, here is a link

Did you try my project?