Download

My map now has 10,000 - 50,000 draw calls in this build.. why???

My map now has 10,000 - 50,000 draw calls in this build… why??? The previous build had around 300 in this room… what could have gone wrong? Should I rebuild? Only thing i did was made grass / rocks foliage not use lightmaps and made them dynamic to try to save on memory … and i merged a lot of geometry to reduce draw calls :confused:

Objects in teh scene also seem to flicker dark to white as though there overlapping geometry, but there isnt :confused:

Whats worse is the draw call spikes only in game mode… not in the editor mode. EDitor mode spikes when u spin the camera by an extra 600 and then lowers back down when u stop moving, but the game mode will go to 80,000 for no apparent reason when u turn a corner.

The following screenshot shows me literally looking up slightly for it to skyrocket… and im talkn 5 degrees rotation lol… moving the mouse a centimeter

can you upload a flickering thing in *.obj / *.fbx?

I have been going back and forth in maya by exporting the scene in fbx and using that to create new props for filling in gaps… so no problem exporting… and it seems like a large portion of the level does that flickering thing… probably everything. But cant say for certain. As I said, before last nights light build… i did not have this problem… i was just optimizing it further… trying to remove lightmaps from some vegetation and have it be dynamic lit… and combined some background buildings into seperate combined meshes.

I did happen to rename the map before i saved and built… still using same terrain and all that… so dont think that could hurt anything :confused:

What if you make your foliage have lightmaps again? Does that solve the issue?

Why do you export the whole scene at once and “merge” objects?
You could use the autosavefunction to get back the working thing, and redo the foliage lightmapstep, restart ue4 to see what causes that.
I had this flickering only when faces overlap 100%, and one time ago while playing with emissive materials on meshes.
https://answers.unrealengine.com/questions/topics/flickering.html

i turned the foliage to have lightmaps again… problem still remains. And there are no faces that overlap… its literally a flickering of the entire scene :confused: makes no sense. The flickering is like dark to bright… as though something is weird with the lightmaps maybe … no idea…And as i said before… the draw calls only shoot up in play mode… The editor floating around mode … seems fine… like 700 draw calls or less most of the time… but in game … any time i turn the camera toward i guess the center of the screen… my draw calls shoots up to like 90,000 for no reason… Flickering also doesnt happen in editor view… only inplay mode.

This really makes no sense. If this is a bug… Who can i send this thing to?

I did notice grass didnt have static lighting enabled, so going to try to build again with that… enabled but other then that… im not quite sure what to do about it.

I tried rebuilding light again… thats still not the issue… its as though the lightmaps for the entire scene flicker dark and bright on every single peice of geometry.

Update. I just noticed something ODD. You see i created the original map with landscape and it was called bathhouse. As I said i wanted to optimize it so i deleted a bunch of geometry modular assets and replaced them with combined versions and saved the map as bathhouse_optimized… Whats crazy when i hit hte play button i see those modular assets from the last version that are deleted already!!! But not in editor view… only in play mode. Could the new scene somehow be referencing the old one? Is it to do with their only being the one landscape??

Updated* I added a screenshot, also another odd thing its not everything from the previous scene… only some of the modular stuff.

Heres another screenshot… that geometry that doesnt exist in editor… it behaves oddly when i move side to side… which is more then likely what the flickering is… overlapping and different places… but its weird… take a look.

Apparently this happens in the old version of my map… so i probably never eve needed to optimize in teh first place very much… i have been experiencing this “glitch” already. So wtf. I dont want to lose a months worth of work … working 8 hours a day every day all month.

As a test… i deleted every single thing except for the landscape just to see… when i hit play mode… it all magically reappeared in the scene. WTF!!! Its not editor outliner or in editor view… just when u hit the play button its all magically there.

When i try the original scene and delete everything except hte landscape… it respawns everything in my scene… and the draw calls are at acceptible levels…

When the 2nd modified scene has everything deleted… it respawns the entire scene on play and the draw calls are at 14,000 instead of 80,000 … but hte original scene that htis was saved from… when i delete everything in that one everything respawns on play and the draw calls coem down to like 700…

Why is stuff appearing if it is deleted? And now im left wondering how many times does it reappear over itself to cause the flickering lol… HELP

I am officially stuck full all stop on development until there is a solution for it… this is rediculous…

How you merged and reimported your meshes?
For example: Merged you “HouseA” and"HouseB" and renamed it to “HouseA” and pressed reimport in UE4?
When you go into the content folder, are your removed meshes there (remove them)?
Try to delete and import fresh, not reimport.
Restart editor before import.

Your really not understanding… I deleted everything out of the outliner… including landscape, foliage… every mesh… INSIDE THE CURRENT LEVEL/map… The assets themselves in the project are fine. Hell most of them are from the unreal market. This isnt an importing kinda issue.

In fact if i copy and paste the entire scene into a new scene… the draw calls are normal even if lighting is not built… as though the problem isnt there… but thats not a fix since copy and paste loses half the stuff… including trees in the foliage for whatever reason.

Think I fixed it. Going to do a few more tests to make sure, but Enable World Composition for whatever reason was checked on. I guess it was somehow trying to merge together every level in that folder or something… there were 2 different levels which were basically the same level with minor changes and they were getting overlayed on top of each other or something… weird stuff.