My landscape layer material won't show when i paint it, why?

Hello, my problem looks simple, yet I cannot solve it.

When I add a new layer and paint it, it does not display.
I have in my landscape material everything working but the last layer, it’s weird because I renamed it correctly everywhere.

Here is the landscape textures

My node if i want grass on it or not

And my RVT texture variations

Setting up the textures (normal color AO etc.) to this :

It did not solve my problem.

I tried to put my rock texture in every other layers and it worked so why wouldn’t it work with the last one i am confused.

What happens if you create an additional layer in your landscape material eg: a copy of your grass? Does that successfully paint grass?

If so - now replace that new additional layer with a different mat other than stone.

If that also works - you’ve isolated the issue must be with your stone texture file / mat!

Hope this helps in some way! This is just the problem solving I’d do. :slight_smile:

Ok so here is my update :

I added another layer like the first one but without grass on it.

I just clear every layers and fill the problematic one :
And it’s actually displaying the material

Then i apply my grass layer on it :

and checker board is back… now it’s my first material that is not displaying…

Then i tried to clear everything again, then fill the grass layer everywhere then i paint the new layer above it and both work.

So is it the textures? because my landscape has only constant like this :

I link into Medium_Grass02 the texture

And the Checkerboard is back omg

So does that mean i cannot have PNG format? I tried TARGA as well did not solve the problem.

Replacing a contant with a texture solved my problem