My landscape dissapears when in game view or in play mode but is visible in editor please help

Recently whenever I click on play my landscape turns invisible but the collision is still there, I don’t know what’s causing this, and by the way “hide in game” isn’t toggled on, please help.

Did you fix it? Is there any workaround or anything?

Thanks for the reply and suggestion, I just tried what you said and unfortunately, it did not work my landscape still disappears.

Had the same bug a while ago, I still have no idea how this could happen…


I’ve done some research and some of the things I found

  • try re-opening the engine
  • check the default settings as shown on the screenshot below (play around with Desired Max Draw Distance
  • switch your quality settings to epic


Hope this will be of some help. Good luck

I remember that when I pressed simulate, my landscape was visible but when I possessed my character it disappeared, as for the other suggestions I’ll try them out when I’ve got the time and I’ll tell you if it resolves my problem.

At least it’s something.
It would be great if you could post a solution over here if you find one, I’m following this topic.
I will try to give it another go tomorrow, there is a solution and it’s probably going to be something ridiculously simple.

Resampling the landscape did the trick now everything works fine, thanks a lot for taking the time to respond.

My pleasure. Always happy to help!

I was playing around with it just now, changed the Desired Max Draw Distance then changed it back to 0 and it did disappear. Couldn’t get to show again. Trying to replicate it now.

Edit: See if you get the same result when you press play for: Selected Viewport/NewEditorWindow(PIE) and Simulate

You can also read this one:

I’ve just had the same issue and changing Resize mode fixed the issue! Thank you very much.

1 Like

Had the exact same bug and your solution worked. Thanks a lot. You’re a life-saver

I had the exact opposite problem, landscape was invisible in edit mode, but was ok in play mode.
Solution : press Alt+L


You need to check “landscape” in Show button, or press ALT+L.

I hope this helped!


Resize mode?

Thank you, the ALT+L solved the issue !

1 Like

Alt L helped me in my situation as well. What does that do? I am having a hard time finding info on it. Thanks! @LeiHeJun

Thank you :+1:

Welp this help, some reason Unreal just untick it auto…lmao