My Gear VR app failed all tests - but I have no idea what's wrong

Hi folks, my first submission to the Oculus Gear VR store failed in spectacular fashion.

Now there are of course bug notes provided. But none of these bear any resemblence to my own testing of the game on my Galaxy S6 in the Gear VR headset. For example all of the bug notes state that the game simply dosen’t run at all on their test devices and instead displays an Unreal logo. When I fire the app up on my device it works perfectly and I’ve never even seen an Unreal Logo on mine.

Here’s an example of the bug notes for all devices.

We were unable to complete testing due to progression blockers. The app launches to the Unreal Engine 4 screen and doesn’t progress any further

Any advice on how to even get to the same test conditions would be greatly appreciated.



Hi Paul,

Unless you can reproduce the issue or provide logs where it won’t load I’m not sure I’ll be of much help either.

The only thing I’m aware of that has been an issue lately is that the libpng security vulnerability has been updated to the latest version on the Google Playstore and they are rejecting any apps that do not use the latest version. From what I’ve seen though this is specifically called out in the apps that have been rejected.

Without knowing much else this would be my suggestion with where to start and integrated the changes into your own project. You can follow the information found here: libpng security vulnerability - Mobile - Epic Developer Community Forums

I hope this helps!


So these are my test results -

Has anyone else encountered such a massive failure?

Are you sure you’ve exported your build correctly? If they’re seeing the loading screen then that usually means you haven’t exported for gearvr (but rather just default android). Did you test exactly the same build they have on your device?

Hi @aussieburger, I tested the exact same build on the Gear VR many times over, the thing that’s confusing me is that I don’t even have aloading screen with any Unreal logo on it.

You mention for Google Play, but I was submitting for Oculus, do you think this isse will exist for both?

I haven’t setup anything for Google Play store, that must be the issue. Out of interest how are you running this? Once I had made my Shipping build I tried running the deployment batch file but it deleted the app on my phone but then I was left without an icon to run the app.

I just downloaded and installed then ran the APK you provided on the S6 I had.

Not sure specifically on the Playstore/oculus store stuff since I’ve never submitted an app for either. Only vaguely familiar with the process.

What was the installation process that you did. I only use the batch file that gets generated.

I downloaded the apk directly to the phone and installed. Because of security issues and phones I cannot deploy any unsigned app from my PC to the phone, even with a batch file.

Are you really 100% sure you tested the exact same APK as what you sent Oculus - I mean did you test with “For Distribution” ticked and running the app not via the shortcut (since it does not exist). FYI: you can create a shortcut using:

Oculus manifest hides the launcher icon for all oculus apps as they want it always accessed over the oculus launcher :wink:

Hi Aussieburger I manually copied the file to my phone and managed to get the broken version that Oculus has been seeing. Question is what am I configuring wrongly?

If your seeing the android loading screen then it’s probably one of the following:

  1. You have enabled the Google VR plugin - this should be disabled
  2. You definitely have Configure the AndroidManifest for deployment to GearVR ticked??
  3. You did not sign your app - did you create a keystore and insert it in: Project Settings - Android - Distribution Signing?
  4. You are doing some special different type of export for the For Distribution?
  5. Perhaps you are using some other plugin that is not supported on Android? (usually this would get a crash though before the splash screen)

If none of those have you tried doing an export of a blank project with For Distribution ticked to see if that works. If that doesn’t work then it could be a problem with the android SDK

Hi Paul, I just wanted to confirm with you that I too have a similar issue, where I’m testing the exact .apk I’m submitting to Oculus on both my S7 and on my client’s S6 phones and while everything works on my end on theirs it shows just a black screen. I haven’t switched to the latest 4.14 version, maybe this will help.

Hello - @Bushey - Can you tell me what ultimately resolved your issue. I am seeing the same thing, although I am getting it for the Oculus Rift…