My game use so much GPU


I have game doesn’t require a lot of resource but still the game use too much GPU

The problem is even in the Main Menu I collapsed every widget but still the game use too much GPU?

ok so whats your question? also you didnt provide any information to work with such as your pc specs, what optimization processes youve tried, or any information or statistics at all. if you want constructive and helpful answers then you will need to provide more.

My question is why my game using too much GPU even though it is doesnt need that much

and when you ask me for my pc info do you mean the problem maybe only in my pc?

I use laptop GT70 nvidia gtx870m with 16 ram and i7

i asked about your pc due to many people trying to make games on potatoes haha just had to check. have you tried using the “stat gpu” command to see where the resources are allocated and being used? whats your scene like? do you have a bunch of highpoly models, complex materials, or translucent materials? also have you tried some of the show and lighting views (like f5 which shows your shader complexity)?

No my game is more like card game, dont have any highpoly models, but as I said the problem happened even in main menu where there is nothing ! really I collapsed every widget in main menu just black screen but still game use too much GPU

and the “stat gpu” command, I didnt try that, I will try now thanks for helping btw

I used the command and this the result

There is some information on how to interpret this information (and get further information) here: GPU Profiling | Unreal Engine Documentation

You can also use stat scenerendering to see your drawcalls. If you’re seeing a high number here, that could be your problem (‘high is relative’, but for the game you describe 1000+ might be considered high)

Finding out what is causing high GPU demands isn’t easy without seeing the game. It could be many things but I’d suggest making sure your textures are sensible (i.e. not huge and probably should be power of 2), making sure that the shaders your using are also sensible (don’t contain loads of material instances or expensive operations - as mentioned above, pressing F5 to see shader complexity will help with this). You should probably check that you’re lighting is sensible too - you don’t want loads of realtime lighting.

Thank you for all the info I did some testing this what i got

so what do you think?

That doesn’t actually seem that bad. Ideally you want to be less than 16ms for 60fps, and you’re not far from that. Draw calls are reaonable too.

What makes you say that you’re stressing the GPU? Have you seen poor performance or some stats which suggest the GPU is being pushed too hard?

That why

My laptop can run way better games without that much use of GPU

Could be my game not optimize for my laptop?

Look even the game Dark Souls 3

dont use that much of GPU

Is this a packaged version of your game, or one you are running in the editor? Does it make a difference if you run full screen or in windowed mode?

I’d suggest it’s also worth running ProfileGPU. With that you can see what is actually taking the time : GPU Profiling | Unreal Engine Documentation (Just yesterday I found that one of my post process effects was killing the game when it was run above a certain resolution by inspecting the information here)

Also, look at your textures. Are they properly optimized? Read this for a few ideas on optimization and see if there is anything you can do: Performance Guidelines for Artists and Designers | Unreal Engine Documentation

It is packaged version

I guess this is the problem maybe?
but what does “HZB setupmips 256x256” mean?

If you want I can send you a copy of my game to try it your self, it’s only like 350mb

Wow, that is a big number! However, I remember reading reports that the profiler might not always be accurate when reporting HZB stats, but it’s still worth investigating (this may not be an issue anymore, but read this: Unreal Engine Issues and Bug Tracker (UE-33448))

So, as this is a card game, how are your textures setup? Are they optimised as per my post a couple above this? Are you spawning loads of particles and are the textures for these particles setup efficiently? If you’re performing a lot of occlusion checks against lots of particles, that could go some way to explain this.

You might want to do a bit of research into HZB and MipMapping to help understand where the problems might lie.

Hey I don’t know exactly what the issue is. But from my limited knowledge, it might have to do with level streaming? I believe UE4 re-renders the map on every tick unless you use level streaming.

I may be completely wrong though.

I have the same problem. I even run a basic template of a fps and it runs my gtx 1070 at 30 percent which seems too much

Hello, I have the same problem, I tried packaging the examples from ue4 and my gpu is at 95%+. I have a nvidia 1070 ti 8gb but I dont think the video card is the problem because I tried to run the game on 3 different pc with different video cards and its the same in all of them and yet if I use stat fps stat gpu and all other commands to see what is using GPU everything is ok. In ue4 the game works perfectly fine.

I solved the problem by disabling SSGI in the project settings