My foliage will not cull since 4.15.0

Foliage isnt culling anymore. My foliage tries to render for miles even though it is set to 10000 units max. This drives my editor to useless mode. 4-15 FPS… All i did was update to the new engine… The bushes are set to cull at like 3000 units which worked fine in 4.14.3, now those bushes you can see a long ways off…

First Screen Shot shows low FPS

Second Screen shot Shows Shader Complexity showing Foliage not culling

Third Screenshot Shows Foliage Setup

Video shows severe Stutter when and poor FPS when foliage is in the viewport This was not a problem in 4.14.3 i would get between 80-120 FPS at all times.

Hey Vindomire,

I was not able to reproduce this on my end. Below are my test results when using the landscape grass system that you are using.

Landscape Grass Culling

Could you try reproducing this in a new blank project and providing me with the steps you took to get the issue to occur?


New project with a single mesh in the foliage from starter pack

Complexity showing foliage way beyond the cull distance

These screen shots were taken at foliage level medium, if i go high i cant even open a window in the editor it grinds my system down so much. If i turn the density to 8 the sparcely populates with grass but i can run it, it puts the grass to the edges of landscape tiles. Ive used both Source and Binary engine with same results.

i7 6700k OC to 4.7ghz
Raid 0 SSD
R9 290 GFX

This test needs to be done in a completely new and blank project using simple/minimal content. The project you are displaying is actually content from the Kite Demo and not from the Starter Content pack.

I just tested it again using the starter content and a very simple landscape material with only a flat color with the layer. The culling is working as intended

Cull Distance


I did make a brand new fresh project. It isnt working right im sorry… Not only is my FPS being crazily dropped even with grass not kite demo (only reason it ended up there was trying all my different grasses to see if it was the models themselves) But the behavior is no where near the same.

In 4.13.4 the foliage was in a circle around the camera, here it seems to be popping in large sections. Also to get it to run decent i have to drop the values to 2000/3000 to even get any decent culling and frame rate. Something has changed.

This video is from 4.14.3, the fps counter isnt showing but i was running between 80 and 120 fps the entire time with 7 different meshes as foliage. The foliage is transitioning nicely in a circle and at ranges set at 3000-8000 depending on type (grass was 10000 bushes 3000).

This is the project i was testing with. It is not culling anywhere near the same as 4.14.3.
Foliage Test Project

After testing in my normal project if i turn distances down to say 1000-1500 it still populates entire squares and pops in when you get close to edges, it is not the smooth transition it used to be.

Thanks for the clear and precise repro steps. I was able to confirm what you are reporting and have gone ahead and entered a bug report for the issue. You can track the report following the link below on our public issues tracker.


Once the issue has been addressed by our engineers the ticket will be updated and reflected in the public tracker. Let me know if you have further questions or need additional assistance.



This happens because your foliage material(s) do not have the “Dithered LOD Transition” checkbox checked. Without it in 4.15 instances will not fade out. Previously if this checkbox wasn’t checked, dithered LOD transitions would occur but would render an ugly black artifact as well.

The flag is under the “Material” category in the advanced properties rollout.

Note that this flag must be set on all materials used on all LODs of your foliage mesh for the dithering and fading to work correctly.

I opened the content you linked above and confirmed that fixes the issue.


This indeed the issue, thank you a ton!!!

I set all vegetation materials and it was A LOT of work and time and now LODs/ vegetation Culls again but my FPS is still 3x lower then 4.14.3

low fps persists

so like I have to apply to some speedtrees dithered LOD to 5 mats is the right, the trees wont cull untill I do even at 10 distance cull untill all mats on a tree at dithered LOD.

I’ve literally done everything and am quite disappointed I fixed all of those map errors converted everything to dithered as they recommend still low as hell frame rate
I got the fill light to work in editor view but in game play it isn’t working correctly
quite disappointing
so no 4.15
or even 4.16 as far as I’ve seen
I’m not the only one to have LOD information transfer issues and culling issues and FPS issues etc…

is giving me a lot of issues in this build. I had to crank it’s intensity and map fill values. But in Play it doesn’t work.

Hello everyone,

I’m currently testing out the grass output node for a terrain material.
From what I can see, the cluster culling depends directly on the section size of your terrain. So if you have big values for your terrain’s section size, no culling might occur.

So if you have like 127x127 section size terrain, try to change it to 7x7, and see whether that works for you!Bear in mind that getting smaller section sizes will add more cost to your CPU, since you are adding more LODs!

EDIT: The stuff above only applies if there is at least one material applied to the grass you want to instance, with the Dithered LOD bool set to false. Turning it to true solved the problem!

You have to change the LOD Group of your static mesh to Foliage