My FirstPersonCharacter is unable to walk up stairs

Originally, the FirstPersonCharacter was able to walk up stairs. Since I reopened the project file last week (I hadn’t opened it for about a month), I had to remove the stairs and make a ramp, because the player is unable to walk up any ledge (even ledges about 1cm tall). I have had to flatten EVERY floor out just to let the player walk around.
Can anyone help me with this? I have already checked the character movement section and the max step height and other stuff related to it is all set to the normal, original values.
Thanks in advance, Bryn Kennedy.

Is your navmesh actually generating on the higher stairs?

Oh, what I mean by the FirstPersonCharacter is the player, not any AI or anything.

Any help?

You probably made your steps too high for the player character based upon it’s default “max step height”. Either make your steps shorter or go to your player character, click on the movement component and scroll down to “Character Movement Walking” and the first thing in the details panel under that tab is “Max Step Height”, default is 45, change it to 75 or whatever you need and your character should be able to climb higher steps.

I have already tried this, and I have set the max step height to over a thousand.

And also it is any ledge, including something that in real life would be less than 1cm tall.

Any help anyone?

I had a similar problem where the player suddenly wasn’t able to get up stairs properly anymore (even with thousands of units for “Max Step Height”) and the solution was to make sure my player is looking straight ahead in the editor. I had rotated it a bit up as the initial view would be nicer but that apparently interferes with the collision/step calculations. Maybe you have a similar issue with a changed viewing angle.

My solution was to slightly increase the length of the steps because there are other stairs in my level with similar steps height, and character walk on it without any problems, I compared these working stairs with not working ones and found that the second had shorter steps, so increasing scale to 1.009 units solved the issue.

Heya @CrowZoneYT, did any of these things work for your problem?