My Controller

Hello There

Im getting frustrated as a newbie!

I can see there are 1st and 3rd person controllers but want to make my own.

I load up the 3rd person default and look at the components used and controller but when i copy these (including adding inputs in project settings etc) I never seem to get a camera looking at my character (I use a sphere). I have the camera on a spring arm to the character capsule. I start from a blank new UE4 file when copying the controller - could that be the issue? I Use the game mode to select MyCharacter.

Its seems like such a simple thing - i don’t understand why the camera view always goes first person and won’t do what the one in the default 3rd person one does.

Hope you can help guide me - i don’t want to go forward until i get this basic idea.


Hey There

Yes - managed to sort it out in the end. There were a few issues. Mainly i was trying to run before i could walk!

This is what helped me in the end:

I didn’t follow the rest of the tutorial but the start explains how you would set up a controlled. I thought id been doing all this but i guess id made a mistake somewhere.

Parenting camera with the right component is very important too if you plan to have the camera follow.

Let me know if that tutorial helps and good luck! Things got a lot easier after i got to grips with the basics. UE4 is amazing.



I’m sorry to comment on this without an answer but I’m having the exact same problem except I started with the blank blueprint. I noticed that you posted on April 2 and I was hoping that you have somehow solved this on your own. I was thinking that I might have to somehow remove tell it to read my character blueprint instead of the blank blueprint ghost style camera. please let me know if you have come up with anything.

Thank you for replying to me!

Did you make your project using C++ or did you use blueprint? If you did how did you get around all the C++ that this tutorial is using? I’m assuming its almost the same.

Blueprints! Did you look at the link? There’s not a sniff of C++

LOL Ok I promise that I clicked on a link but it was all C++ and I tried to work through it. and I just clicked on it just now and it looks completely different I’ll get back to you after I’ve checked this new one out. Thanks again!

OK well it worked… but I came across a problem i don’t think you had. Because mine was a blank project there was no axis mapping for the LookUp, MoveForward or MoveRight. I had to go into the project settings which can be found at the end of the edit menu.

I had to change the Axis mappings in the input under engine. I only knew about this thanks to me mistakenly going to the wrong link!