Download

My Character Won't Walk Again After First Time Running

Hey everyone, I’m having this issue with my character where it will walk at first, and then after the first time you press shift to run, it won’t walk again. The character will stop and turn, but when you try to walk it just runs without shift even being pressed. I’m using a state machine for the animations and I’ve tried messing with the transition rule speed numbers from idle to walk/run state with no success or change. Any help is much appreciated!

  • Nick

Do you have a screen shot of the state machine and the transitions?

Yes, sorry, I should have included it in the first place.
SM
BP
BP_2
Do you think it could be caused by the fact that these 2 blueprints at the bottom are separate blueprints?

It could be that you aren’t using input bindings, but I have no idea that’s just a guess. If you’re using one blend space for walking and running, there might be a problem with the blend space. Also, the default Walk Speed for a character is 600, so that might help.

I don’t have that much experience with animations, but I hope I can help.

Could you elaborate on input bindings? I haven’t heard of them. Thanks for your help!
I am using axis mappings and action mappings if this info helps.
Action_Mappings

Yeah, ActionMappings. Sorry if it was unclear. In your blueprint where you set the Max Walk Speed you are using a Left Shift Event instead of your Run ActionMapping Event.

So I just changed the left shift event to my run action mapping event and it didn’t change anything, still having the same problem. I feel like that blueprint isn’t actually being used at all.

Does your character speed up and slow down like it’s supposed to?

It works as normal on first launch. I can start walking and then press left shift to start running but then if I stop and start going again it just runs at the same fast speed no matter if shift is pressed or not.

Then it’s a problem with the last blueprint where you set the Max Walk Speed.

I actually just confirmed that the last blueprint you’re mentioning with max walk speed is not active. I deleted all the nodes and compiled/saved and tried playing again with the same function and issues.

So something interesting I found out that might be able to help a smarter person narrow down the issue: I changed the run speed in my character class default settings to something really low like 100 and now the character does the walk animation at the slow speed WHILE the shift is being held! And without shift being held the character runs fast! Really weird.
Also, I found the actual blueprint that is controlling the movement.
Run
Jump
Move_Forward
Look_Up_Down

EDIT: OH!! I just figured out the issue. The max walk speed upon the shift being released was set way too high at 700. Thanks for all of your help @GamionGamer !

1 Like