Download

My Character Keeps falling through static mesh

Hi everyone

I am pretty new to the Unreal engine but I am trying to create an architectural walk through of a model taken from LIDAR scans. I have the model in an .OBJ format which I have been able to bring in fully textured. I have created a plane which the building sits, and tried to set a number of the settings for collisions with the capsule and the static mesh. However when I press play, the player always appears under the model and the floor.

Wondering if anyone can help me get the right settings so I can walk around the building, setting up the collisions accordingly.

Any help would be greatly appreciated

Thank you

Jonathan

Here’s how to set up collisions: https://docs.unrealengine.com/latest/INT/Engine/Content/Types/StaticMeshes/HowTo/SettingCollision/index.html

Also make sure your player start actor is above the ground, that sets where the player is when the game starts.

Perfect, thank you very much for your help, this has helped a great deal!!

Please check the thickness of the floor. I have noticed that sometimes small objects like (Grenades) go through the floor. The default thickness is 16, try “32”