Download

My character is not playing movement animation

Hello,

First I hope I posted in the right place.
I have a problem…I followed the 3rd Person Game with blueprints video tutorials.All good until I run the project so I can play.The character is moving but is not playing the animation with his legs and arms while he walk/run.
Does somebody know which could be the problem ? :slight_smile:
Thank you!

It could be any number of things, you’ll find a faster response if you post some screenshots of the set-up…

The first thing I would check is that the correct animation blueprint has been assigned to the character skeletal mesh in your character blueprint.

http://s28.postimg.org/vjw81t3hl/image.jpg
http://s20.postimg.org/7fh3p7ggp/image.jpg
http://s20.postimg.org/nt5om3lzt/image.jpg
http://s20.postimg.org/5vgd4jxg9/image.jpg
http://s20.postimg.org/6elgdtoux/image.jpg
http://s20.postimg.org/e28cw4nix/image.jpg
http://s20.postimg.org/eg9ovq7mh/image.jpg
http://s20.postimg.org/mzt2thfyx/image.jpg
http://s20.postimg.org/b31g90e1l/image.jpg
http://s20.postimg.org/z825qpyc9/image.jpg
http://s20.postimg.org/unfzbsemx/image.jpg

Ok, so these are the pics with the setup.Anyway I will try to take all the videos from beginning. :frowning:

Have you checked that the character skeletal mesh has the animation blueprint assigned to it in the details pane of your character blueprint?

Oh, I think I understand what you mean now…Could you post a screen shot of the animation bp event graph?

I assume the idle animation is playing when he walks right? Check that your speed variable is being updated

http://s29.postimg.org/nez2lorir/image.jpg

Yep, that’s the problem.My idle animation is playing while my character walks.Where can I check if my speed is being updated ?Sorry but I am very new to UE4 and I don’t know where to check. :slight_smile:
Thank you very much for helping!

Apologies for the late reply, I’ve been on holidays…

Looking at the image I can see that you have nothing plugged into the speed variable. You’d need to plug the output of the vector length into the speed node if you have not yet solved this.

Sorry, for necrophilling, but I have same problem. And I pluged the output of the vector length into the speed node. And, now i have new problem. The lagging animation. Like this:
http://gif.targem.ru/view.php?id=851…ae27431e&t=mp4

What’s problem? How solve this?

My conection screens the same like Alex119.

I solved it. I have forgotten to delete old connections. I think nobody run to it.

I’m having the same problem. Earlier recommendation was to check that speed is being updated. How would I go about doing that?

I am using the Paragon Characters, and a simple move AI to. it works on the UE4 Mannequin but not the Paragon Characters. Can’t figure it out. Any help is appreciated.