My character is not moving. I need help finding the cause.


Despite setting up the images as shown and pressing play, the cube does not move. After configuring the AI controller and linking it to the character, I placed the Nav Mesh and the character in the level. When I play the game, all the text output nodes work correctly and indicate that the movement was successful, but the cube character does not actually move. I need help finding the cause.

Hey @heade86! Welcome to the forums!

Are you intending to use the white cube as an AI actor? If so, you will need to change its collision to something that isn’t static, such as pawn, and redraw the Navmesh.

The problem is that the navmesh is seeing that cube as part of the level- so it’s putting a gap in the navmesh underneath it. AI Agents that are not on a navmesh can’t move! :frowning:

Hope this helps! Let me know if this isn’t enough help, and bring more details if you need additional help! :slight_smile:

Thank you for your response.
I replaced the actor with another character to see if the issue was with the actor, but the character still doesn’t move. The character is from the default third-person project, and I only connected the BP_AIController from the image after removing the Event Graph. I didn’t change any other settings.

Why is my character not moving?

Hey, sorry for the late response, @heade86!

So here you’re passing in your AI controller as the TARGET actor, which would be the goal. You need to use the Pawn input to move the pawn/character. :slight_smile:

If that doesn’t fix it, try using the “MoveToLocation” node instead!

Let us know how that goes and I’ll get back to you!

Thank you so very much.

As per your advice, I used the ‘Move to Location’ node instead of ‘AI Move To’, and I confirmed that the pawn correctly moves to the specified coordinates. However, I am curious about why ‘AI Move To’ did not work.

Some people have issues with AI MoveTo, it varies on a case by case basis.

Others have similar issues with “PlayMontage” and its several variations!

I’m glad we were able to help! Don’t be afraid to reach out if you have any additional problems! :slight_smile: