Download

My character is "in the air" during death animation - problem with the capsule

Hello,

I have a strange problem with the CapsuleComponent:
39d7279aec56211615d54a0f8ec1dd3be13bd76e.jpeg

The character is “in the air” during the death animation. How can I fix that? The capsule is inherited. I tried to switch off the capsule collision but I was unable to.

Just looks like the animation isn’t right…I’d check your animation and see if it’s level with the ground or if he hovers there as well…

Thank you for your suggestion.

I saw in Persona that he hovered in the animation view (the animation viewport) too. The animation is from the Animation Starter Pack. Earlier, when I used the UE4 mannequin, all seemed to work right, but then I replaced it with my mesh from Makehuman. It’s the problem with the capsule I think. He hovers because of the capsule that is still standing vertically while the mesh is horizontally during the death animation.

I can’t say I know the first thing about the provided animations as I make the ones for my game but if he hovers in the viewport then it’s the animation…the viewport doesn’t have a capsule on it…or anything really from the Character Blueprint used in your game…Maybe the pull the actor lower when he dies…I can’t say what would work best other than changing animations but at least you know it’s not the capsule…

Thank you for your suggestion. The animation in the viewport:
8f476ea17b283608e49eb7e367843f76cb66fc6b.jpeg

FIXED!

I just used a different character (with a probably different skeleton), so to retarget successfully, please do not forget:
Typically you’ll want to use those settings for bipeds:

  • Root Bone, IK Bones, weapon bones and any kind of markers to use “Animation”, so they come out unchanged.
  • ****Pelvis ****will use “AnimationScaled”, so it sits at the right height, and is still animated. And any other bone you want the translation to be animated AND retargeted.
  • All other bones will use “Skeleton.” They will use the fixed translation from the Target skeleton (The skeletal mesh the animation is being played on).

This happens to me also. I use the same animation for both the main character and enemy. When the character I controls dies it falls to the ground. But when I kill an enemy it doesn’t fall to the ground if I kill it while it is in the air.

I was having a similar issue and switching pelvis to AnimationScaled did the trick!