My Character is few units above the floor

My Character blueprint is still about 3 units above the floor (its capsule half height is 50 and if I spawn it 50 units above the floor its Z location changes to 53.15 automatically after starting the game). This is a big problem for my game.
The same problem is in Third person blueprint template:

How to fix it ?? Please answer quickly.


  1. open your character BP
  2. Go to components tab
  3. Click on the mesh
  4. Drag it down using the widget so its feet are closer to bottom of collision capsule
  5. Celebrate!


This my test object. Please explain again what I have to do.

You will need to adjust the size of the capsule radius and half height as well as the scale of ball character until the results are what you like. You can enable seeing the collision in the Viewport settings, that way you could see exactly what is colliding.

I have the same problem I can’t fix it

You should open the character BP and simply drag down the skeletal mesh on the Z axis :3