My character does not rotate along with what it is standing on when UseControllerRotationYaw is unchecked. Why?

When my character is standing on a moving static mesh, it does not rotate along with it unless UseControllerRotationYaw is true. However, I need it false as I handle yaw rotation by calling a custom function from tick.

With UseControllerRotationYaw CHECKED the character does rotate with what it is standing on. With it UNCHECKED it does not.

could it be that your custom function handling the yaw is the problem? what happens if you disable that but keep UseControllerRotationYaw unchecked?

I can confirm that even without calling the custom function, the character does not rotate along with what it is standing on.

Weird…I’m not familiar enough w/ character physics to suggest anything further :confused:

Hello BlackRang666,

What kind of character are you using? Is it something akin to the First Person template or the Third Person template? What method are you using to move this static mesh “platform” that the character is standing on? What component are you setting this UseControllerRotationYaw setting on?

It is similar to the FPS character. I am setting the transform of the platform in that actor’s tick. UseControllerRotationYaw is of the character movement component.

I am thinking this could be an engine bug, because even when I do not use any custom functions to affect the character’s rotation, unchecking UseControllerRotationYaw is enough to stop it from rotating properly.

Thank you for that information. This seems like it may be related to the way that you’re rotating/moving the platform. If I take a base blueprint with a static mesh component and then add a rotating movement component, the character turns with the static mesh when standing on top of it despite the bUseControllerRotationYaw setting. Could you give that a try just to see if you get the same results?

Another possibility is the simulate physics setting on the platform. If it is simulating physics, it won’t affect the characters’s rotation as the character isn’t simulating physics. You’ll need to disable this setting if it is enabled.

My platform is having its transform set during its tick. I tried using a platform with a rotating movement component and got the same results. Then I noticed an option in character movement UseControllerDesiredRotation. Checking this option causes the character to rotate appropriately with what it is standing on, and essentially does what my custom function did, so I modified that function to change the rotation rate. It is working for me now, but still seems strange that rotation does not work unless UseControllerDesiredRotation or UseControllerRotationYaw is checked.

Could you try using the base First Person Template project and the rotation movement component? I’m not seeing any of the issues you’re experiencing unfortunately. I’ve had neither of these options enabled yet the character is rotating along with the platform without a problem. The function that you posted above in your original post, is it being called on Tick directly or is there something else going on as part of that?

We haven’t heard from you in a while, BlackRang666. Are you still having problems getting your character to rotate along with your platform? If so, have you tried what I suggested in my previous comment just to see if you can at least get it to work with the base assets and a rotating movement component? In the meantime, I’ll be marking this as resolved for tracking purposes.