Download

My Camera actors are Bugging in all weird ways and I'm losing hope

I have posted this question in a different part of the forum as well, but don’t seem to get a response in any way. I’ve been working on this project for 4 years, only know some visual scripting, and I don’t know what’s happening.

You can find my orignal post here. But I will repeat the issue below, including my recent discoveries.

To be able to use and buy a specific plugin (Marcis PS1 effects -which I haven’t bought yet) I had to upgrade my project from 4.16 to a newer version and I chose 4.27. Everything seems to work just fine, except for anything involving a camera actor. There is a whole collection of weird things going on whenever I play the game in editor or select a camera actor. Be it either a new camera I drag in, or the existing cameras I have already placed. I have no idea what is happening or how to fix it. I wasn’t able to find anybody with similar problems.

Here’s what’s happening:

  1. Whenever I select a camera, the preview is not correct and only shows the camera view in the top left corner.

  1. Whenever playing the game in the editor or in a New Editor Window, the view is not correctly rendered. On the left side everything seems to be okay, but on the right side the camera just refuses to render almost a third of the view. The view also seems squished.

  1. Widgets still display correctly as I have originally built them.

  1. When playing in a new editor window and stretching the screen, the rendered area seems to get smaller and smaller the more I size the window.

  1. When Piloting the camera actor you can clearly see part of the view not being rendered. The purple borders are the frustnum. Yet the level grid shows, as well as trigger / collision boxes.

  1. When viewed from above in perspective mode, the view weirdly seems to split in a V shape, originating from the camera, in which my level geometry points to the top left corner, but somehow all triggers to the top right. Also again, the rendered view gets smaller (as noted by the blue box).

  1. I’m not doing anything weird or abnormal with these camera actors. Just standard ones I drag in with basic settings.

What can I do? I’m totally lost for solutions. The same seems to happen when opening this in UE4.26. Everything else works just fine, only this seems totally broken.

Thanks for your time and any help you can provide!

Does this happen in a clean 4.27 project?
Does this happen if you move your project from 4.16 to next version?

1 Like

This does not happen in a new clean project. None of the issues are present there. Everything works normal.

And do you mean I should try move it to 4.17 first? I’ve only tried with 4.26 and 4.27, it happens in those two.

UPDATE: I’ve also posted to Reddit, and will post new findings here in case it turns out to be important. I ran the game in editor, then ejected. This happened.

  1. The view when running the game in editor.

  2. I eject the cam, then it looks like this.

  3. I start stretching the screen and this happens.


  4. I quit the game back to the editor. All collisions seem misaligned.

  5. I turn the cam to the right in perspective view. The V-shape splitting issue seems to be happening again. Almost as if I was looking through 2 cameras. It makes me kinda nauseous actually. You can also see the floor at the bottom cutting off.

-yeah to 4.17.
-what if you run it in standalone? and what resolution you have set in project settings?

1 Like

-Also try to disable constrain aspect ratio.
-Try to delete all the camera actors that you have created. (If its a camera in world just delete it. if you have cameraBP delete that save and restart the project. Add the cameras. Test it. if it works then manually create cameraBP and manually copy pasta code.
-Is it c++ project?

1 Like

You should literally never update engine on projects you are working on, particularly when they work.

I hope you can revert back.

If you can, just buy the plugin, install a version of the engine compatibile with it. Create an new project, and then manually reproduce the plugin within your working engine version.

.27 is plagued by issues.

Another “patch” which could get the .27 version to run ok would be to grab the latest source of .27 and build it yourself.
I have to do that just to be able to use .27 currently. As the launcher version just bugs the UI out.

That said.

Your CAM_player_cam
Is what exactly?
What is the parent class? Is it custom cpp? Or just a piece of the engine which probably got updated from under you causing the problems?

The issue could be as simple to solve as to override the class cpp and h files with the old source code and build the engine from source (to just replace it).

Or, you can create a custom class in CPP, and feed it the same .h and .cpp that the engine of the working version uses.
Then switch the patent class in the BP to the one you created.

It all depends on what components were used really.

I would still revert back to the old version and work the plugin into it manually

1 Like

Hey guys, a million thanks for helping me out! A few answers:

  • The resolution is set at 1920*1080

  • I’m not using any c++ in this project, I only know how to use Blueprints - and after 4 years still learning. I’m a modeler by trade, a thing like C++ I can’t really comprehend.

  • This is also why I don’t know for sure if I can reproduce a plugin like that, I was planning on using it out of the box. It’s this one that I was planning on using. It’s got all custom menus and such, and I have literally no idea on how to do that.

  • I need to try out installing 4.17 (downloading now) as well as the other suggested things. I will try it tomorrow, it’s already 3AM at my place and I’ve been going at it since noon :sweat_smile: UPDATE: all works fine in 4.17 - time for bed now, will move up to 4.18 tomorrow!

  • CAM_Playercam is a Blueprint. It’s parent is a CameraActor. There is some blueprint script on it to make it act correctly in certain situations (zooms, only move along a single axis and such). The only components used in this BP is a Scene Component and a Camera Component.

  • Even if I drag in a basic, clean, new cam the same bugs show up.

  • I don’t know what an .h file is or how to do that last bit with creating the custom class.

  • I can easily revert, I make daily builds and backups (twice). It’s just that I’ve been struggling to get this to work for 3 days already.

  • Maybe useful information or not, I don’t know: the only other plugin I use is FMOD.

I’m gonna slowly try and work my way up from 4.16 to 4.24 (it’s the minimum version the plugin requires). If that doesn’t work I’m afraid I have to stay at 4.16. It’s too bad, because literally everything else seems to work well. Playtesting the game for a couple of hours I haven’t run into any other bugs further.