Download

My basic mod causes an error

I am a total noob and have a lot to learn, hoping someone will know why this happens

Fatal error!

ShooterGame.exe!FArchiveProxy::GetLinker() (0x00007ff74cc28e04) + 4 bytes [f:\ue4\unrealengine\engine\source\runtime\core\public\serialization\archivebase.h:1114]
ShooterGame.exe!ASupplyCrateSpawningVolume::CheckForSupplyCrateStart() (0x00007ff74c820e56) + 28 bytes [f:\ue4\unrealengine\projects\shootergame\source\shootergame\private\supplycratespawningvolume.cpp:60]
ShooterGame.exe!ULevel::RouteActorInitialize() (0x00007ff74d497212) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\engine\private\level.cpp:1720]
ShooterGame.exe!UWorld::AddToWorld() (0x00007ff74d68cc6c) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\engine\private\world.cpp:1843]
ShooterGame.exe!UWorld::UpdateLevelStreamingInner() (0x00007ff74d68fcf5) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\engine\private\world.cpp:2483]
ShooterGame.exe!UWorld::UpdateLevelStreaming() (0x00007ff74d690014) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\engine\private\world.cpp:2566]
ShooterGame.exe!UGameViewportClient::Draw() (0x00007ff74d3f8855) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\engine\private\gameviewportclient.cpp:878]
ShooterGame.exe!FViewport::Draw() (0x00007ff74d64f65e) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\engine\private\unrealclient.cpp:1082]
ShooterGame.exe!UGameEngine::RedrawViewports() (0x00007ff74d3d0b41) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\engine\private\gameengine.cpp:405]
ShooterGame.exe!UEngine::LoadMap() (0x00007ff74d666ba1) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\engine\private\unrealengine.cpp:9445]
ShooterGame.exe!UEngine::Browse() (0x00007ff74d661a32) + 38 bytes [f:\ue4\unrealengine\engine\source\runtime\engine\private\unrealengine.cpp:8200]
ShooterGame.exe!UEngine::TickWorldTravel() (0x00007ff74d6626e0) + 65 bytes [f:\ue4\unrealengine\engine\source\runtime\engine\private\unrealengine.cpp:8372]
ShooterGame.exe!UGameEngine::Tick() (0x00007ff74d3d27ac) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\engine\private\gameengine.cpp:921]
ShooterGame.exe!FEngineLoop::Tick() (0x00007ff74c518409) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\launch\private\launchengineloop.cpp:2334]
ShooterGame.exe!GuardedMain() (0x00007ff74c512acc) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\launch\private\launch.cpp:139]
ShooterGame.exe!GuardedMainWrapper() (0x00007ff74c5198ea) + 5 bytes [f:\ue4\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
ShooterGame.exe!WinMain() (0x00007ff74c519a18) + 8 bytes [f:\ue4\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:209]
ShooterGame.exe!__tmainCRTStartup() (0x00007ff74e534901) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
KERNEL32.DLL!UnknownFunction (0x00007ffe37f02d92) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffe3a049f64) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffe3a049f64) + 0 bytes [UnknownFile:0]

Make sure your PrimalGameData is not referencing a TestGameMode file invalidly(i.e outside of the mod folder).

-WM

Thank you :slight_smile:

got it working, only one problem when I come to place the new item in the game it does not remove it from my inventory like it makes a copy. Any ideas?

EDIT: I found it, needed an entry to consume structure