Download

My AI is seeing through collision!

I’ve made a custom collision in Maya and imported it successfully to Unreal. I am now in the process of making my very first AI so I’m very new to all of this, but the thing that I don’t get is why my AI is seeing through the collision, even though I’ve set my collision to block Visibility in the Trace Responses options.
On the AI controller for the pawn, I’m using the AIPerception component and in the Sense Implementation settings I am using sight.
I’ve followed multiple tutorials on setting up a Behavior Tree, yet everything yields the same results, the bad guy can always see through the collision!

Create a custom object/trace channel … Project Settings → Engine → Collision … Add a Custom Object Type to Your Project | Unreal Engine Documentation

Use this channel to block.

Hm, I’m not sure I follow. I created a new Trace channel and set it to Block, but how do I tell Unreal that I want to be blocking sight?
Thanks anyway for the response!

Are you using the AI Debugging Tools ( AI Debugging | Unreal Engine Documentation ) to check if the AI is actually seen you behind an obstacle?