Download

Mxing morph targets and skeletal animation in sequencer...

I have managed to import a character model with animation and morph targets into unreal from 3ds MAX. The problem is that if I overlap a morph and an animation (say a blink on the idle animation) in the sequencer, then the bones are also blended, and half and half result occurs…so the eyelids half close and the arms half blend as the eyeblink animation arms are in the A pose for example. Basically I would like the morph animation to completely disregard any bones and only affect the vertices that have the morph target applied (which I had hoped would be the default).

Ways to get around this…but I don’t exactly know how, is :

  • Mask areas of an animation similar to using animblueprints…but on an animation that can be dragged onto sequencer. From what I can tell masking is either more for blueprint controlled features. Meaning I’d have to set variables in the sequencer to trigger states? I guess this might be the way for this?
    Controlling Anim Instances with Sequencer | Unreal Engine Documentation
    That said, I would much prefer to drag drop animations into sequencer rather than trigger variables every time I want to do this.
  • Is there some button that allows an animation to disable skeleton, I found Disable Morph Targets. That way when it is blending between the two animations, the skeleton is not taken into consideration at all. This would probably be ideal
  • Detach the head mesh and not use any other bones with it. that way the head does not take into consideration bones to blend with as there is only one to deal with. I’m sure there is a way to blend bone and morph targets though.
  • There is some magical method of accessing/animating morph targets on a model inside the sequencer? If there is I haven’t found it after two days of going down this rabbit hole.

Any help would be GREATLY appreciated.

So, what you are saying is that both the Morph target and the actual Bones are moving at the same time?

Wouldn’t this depend on how you set up the animation?

You probably just need to animate the mesh correctly. You either use the bones, or the morph target.
The morph works with a curve setting. The curve data is exported along with the animation.

I do not believe matching names cause the behaviour you are describing either - as I myself have a custom asset where morph names match bones but no issue at all when properly animating.

as far as sequencer goes, you are better off getting it to play a specific animation then trying to override curve behaviour, but if you want to waste some time you can get it to also change curve behaviour.
At that point though, you can probably just override the morph target on tick event by constantly setting it to 1 or 0 via BP and save your self all the extra work?

So I ‘think’ I figured it out by turning Local Space (I think it was) on in the animation that had the imported morph targets animated. It’s an option in the left of the… Animation section I think? The bones don’t seem to blend anymore with that setting. I have more testing to do to confirm but that seems to have done the trick with my first simple test.

In my original morph target animation (in 3dsmax) there was no animation, or keys, set on the bones. It was just in the A-Pose. Morph targets had keys though.

I also tried deleting the bone keys in the morph target animation in unreal, I found an option for that in the animation panel pull down menus, but that didn’t seem to work either.

For now though, maybe I have my answer. Thanks for your input. I’ll take any learning and alternatives when I can!