Multiple physicle materials with Layer Blend

I am having a problem determining, what material my vehicle is on.
My goal is to spawn according particles under the vehicle.

I followed some tutorials but I seem to have overlooked something. I have no idea, what that might be and beg for your help.

The problem is: Though I followed the instructions step by step, my screen looks as follows:

Marked to the left is the surface type, which is always default. It should be *Lehm *(Clay in German, sorry).
The marked white box is the hit from the linetrace. It is under the landscape, because the landscape has some displacement.

What has happened so far:
To give you an idea, what I may have missed or done wrong, this is what happened.

First I entered all the surface types I might need under the project settings.

Then I made one *physical materials *for each surface type. Marked is the setting for the surface type, as that seems to be the relevant information.
I didn’t change the physics settings at all.

Then under *Landscape *> *Paint *I selected the Layer Info Assets and opened them.

For each *Layer Info Asset *I selected the according physical material, that has the *surface type *in it.

And finally in the *blueprint *of the vehicle Actor I generated the line trace.
The *Hit *should have delivered the surface type, which doesn’t work.

I thought to have understood, what is happening here. But there is obviously a gap, that I can’t close by myself.
Just for testing, I then set the physical material of the landscape material to ice. That didn’t change anything either. So I seem to have missed something basic.

Thank you for reading so far and I am looking forward to some hints and wild guesses :wink:


I made some more testing and the problem is located in the Layer Blend.
Placing some Objects and driving on them return the expected surface type.

Any help is appreciated, thank you.

This morning I found this: [Problem/Bug] [UE4.24.1] Landscape surface type always return "Default" - Engine Source & GitHub - Unreal Engine Forums
It says (01-29-2020), the issue has been fixed in the new Hotfix.
I guess, it means 4.24.2, right?