Download

Multiple inputs on character not working at once

I’m new here and not sure if this is the correct place or not, but I wanted to report this and maybe someone can help. I have inputs set up for crouch and interact (Same as I would in UE4). Crouch is left ctrl and interact is E. If I hold crouch and try to interact with intractable actors the interaction input will not run. I’ve tried unchecking the consume input, but no luck.

Does the E trigger the input event even if it doesn’t work?

If it doesn’t trigger: how did you setup for the BP to listen to inputs?

When holding crouch it does not fire the interact. I have them setup in the inputs in project settings and in the character’s class. They don’t have any overlapping keys either. I included the inputs and the function the interact calls. Ive tested with print string and break point the interaction input never fires off when I’m holding crouch.


Just a thought, we have had issues where some cheap keyboards won’t recognise multiple key presses at the same time (i.e. the hardware itself).
Have seen this with multiple HP and Dell branded keyboards that come with packaged PCs.

Just thought it might be worth mentioning.

I just tried to use a controller and it worked fine. I am using Razer Chroma which isnt that cheap or some basic keyboard imo. I also have used it on games and it works fine. So not sure whats happening

After some testing in UE5 was able to replicate and “fix” the issue.

This is the problem:

You need to go to Editor Preferences and change/delete that shortcut. It’s somehow blocking the input combination.

This should be reported as a bug.

1 Like

Yes! Thanks for the help, that fixed it.

1 Like