Download

Multiple crash issues

I am at the end of my project. My game is done, and ready to go into alpha testing. It has been done since Friday night. However, since Friday night, every time I open the project, it crashes. I have sent every report. I have created new projects and reloaded my files into them. I get the same result. How do I fix this issue? Here is the most recent crash log, if that gives any idea as to what the problem might be:

MachineId:8FB3F056422BC59640E019A8583D9BC4
EpicAccountId:0a6407acf3b244459915f787b431a4f8

Unknown exception - code 00000001 (first/second chance not available)

"Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Core\Public\Serialization\Archive.h] [Line: 96]
FMemoryWriter does not support da

UE4Editor_Core!FDebug::AssertFailed() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\misc\outputdevice.cpp:374]
UE4Editor_AssetRegistry!FMemoryWriter::Serialize() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\serialization\archive.h:96]
UE4Editor_Core!operator<<() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\containers\string.cpp:1108]
UE4Editor_AssetRegistry!operator<<() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\containers\sparsearray.h:413]
UE4Editor_AssetRegistry!operator<<() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\containers\set.h:642]
UE4Editor_AssetRegistry!operator<<() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\assetregistry\public\assetdata.h:329]
UE4Editor_AssetRegistry!operator<<() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\containers\array.h:1210]
UE4Editor_AssetRegistry!FAssetDataGatherer::SerializeCache() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\assetregistry\private\assetdatagatherer.cpp:541]
UE4Editor_AssetRegistry!FAssetDataGatherer::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\assetregistry\private\assetdatagatherer.cpp:238]
UE4Editor_Core!FRunnableThreadWin::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]

Have you tried starting the editor without haveing it load a project?
Have you tried restarting windows?
Have you tried running the editor from VS, There by VS should bring you to the location of the crash where you can start debugging/diagnostics.

HTH

I have restarted Windows. I have opened a new editor project, and migrated my files over. I have tried reinstalling UE4. All other projects will open just fine. It is just this game, no matter what I do, will not open. When I create a new project, the second I change the game mode to my game mode, it crashes, if I add ANY nodes to the Begin Play in the default level bp, it crashes. I have spent two months on this mobile application. It has run fine up until I started getting ready to package it out. After attempting that, all it does is crash.

Do you have a C++ gamemode class that you are using?
If so: You could be trying to use something that is invalid (IE: Trying to create a pawn/character that could not be found).

HTH