Download

Multiplayer not working after following UE4 tutorial

I was following along the Multiplayer Blueprint Tutorial that is on the UE4 youtube and got to part 11 and tried testing the multiplayer with my friend and it said no sessions were found, LAN or Internet. I tried it on another computer in my house and no sessions were found either. I went through the video again to make sure I had everything. The multiplayer connects when i have 2 players in the editor but when i package and try 2 instances of the game running on this computer it doesn’t work. If you need screenshots of any blueprints just ask.

Make sure you are using TWO DIFFERENT Steam accounts. Make sure both are open and you can see the steam overlay (sometimes people disable this). Make sure that under Steam->Settings->Downloads->DownloadRegion both are the same.

If you still have any issues after this, let us know.Or go through the tutorial real quick to make sure you didn’t mess something up. Not saying that that tutorial is without its own faults…

  1. Development
  2. My friend lives about 10 minutes away from my house so yes
  3. I didn’t see a steam plugin. The only ones with steam are the steam controller and VR. I do have the scripts in the file though.

I copied and pasted this into the defaultengine.ini and the steam plugin is not showing up as a plugin. Neither do I have a tab for “Online Platform” tab in the plugins menu

It says on the online documents that it comes pre installed 4.7 and on but im using 4.12 and its not there

But before you go and reinstall the engine, check through all of your variables and nodes of your blueprints to make sure that the server can talk to all of the code that it needs to talk to, for sometimes a missed variable or a variable not checked for the server to communicate with can cause issues as well.