Multiplayer - Client input does not work

Hi I have created a multiplayer game using the video series from Epic. In the Lobby, I want players to be able to move around and pick up items. I have created an item with a trigger, and when the server and/or the client enter the trigger box I can generate a widget on the screen instructing them to press Y to pick up the item. However I can only get a script to work when the server presses Y. The item disappears and replication works fine. However when the client is in the trigger pressing Y does nothing. If I set up a blueprint that when you press Y a printstring occurs - everything on the client is fine - the message appears. So the input works but not with the item.
I have looked at numerous posts with similar problems but there is no solution apparently. The player controller is the LobbyPC from the series.
If I dont have a key input to pick up the object and just have the client collide with the object I can get it to disappear. However with the extra step of a key input it just freezes.
If anyone can help it would be greatly appreciated.

Show the blueprint code from the input event to the function call that isn’t happening.

I have actually tried heaps of blueprints - on the trigger sphere itself, the level blueprint, the Lobby Player Controller, the Third Person Character and none work. I did a simple E is pressed and print string “Hello” and that works on both Server and Client. As soon as it casts to the 'Can collect Boolean the client does nothing. I can post pics but as none of them work I was hoping someone can start me from scratch. Not even sure if the way I am doing the 'pick up widget is correct or if I should do a line trace. Basically I want pick ups that work in multiplayer that work like those in Fortnite as an example.

Without seeing your code I can’t be sure but it sounds like you need to learn about RPC. You need to have the client call functions on the server or they won’t happen in the world for everyone. The place to start learning is here. It also sounds like you may be using actors on the client that are not replicated properly.

You can try a tutorial such as this and ask questions when you get stuck. But beyond that you shouldn’t expect much hand-holding.

Thanks for taking the time to reply. I actually do understand replication and following the Unreal tutorials everything is set up correctly and everything else does work fine. I am just stuck on this one thing as are a number of other people by the look of things. I have tried at least 30 different combinations of codes including simple destroy actor off a key press to replicated custom functions. Rather than posting 30 screenshots of failed codes I wanted to see if anyone had a similar problem and a solution for me to work towards

Just post what you have.

Oddly enough I’m experiencing something similar. I’ve just finished implementing the Steam Party plugin and I’ve got something similar but worse happening. For me the client literally can’t do anything. They can’t move, they can’t open a menu… all input seems to stop working except they CAN open the console. I don’t understand what went wrong. Did you ever figure out your issue?

hi, i have the same problem. Could u fix it?