Download

Multi View Issue with materials /normals in Andriod build ! and viewport

this does this on a clean vr project help appreciated.

it seems maybe something to do with forward rendering? I am not sure. i followed the list below

i followed this guide 100%

  • Select Mobile
  • Enable Multi-View (it’s instanced Stereo for Android)
  • Enable Direct Multi View
  • Mobile HDRI: Turn off
  • Enable Fullscreen Immersive on KitKat and above: True

Checklist Summary for Unreal Project Settings and Configuration:

  • Start in VR
  • Reflection Capture: 512 (adjust for performance dependent on your scene)
  • Forward Shading for Desktop: Not True
  • Development is done with Shader Model 5 for Desktop and ES3.1 for Android
  • Default RHI: DirectX12
  • DirectX 11& 12 (SM5): True
  • DirectX Mobile Emulation ES3.1: True
  • Antialiasing: MSAA: true * I set maximum 8×8
  • Instanced Stereo: Turn off [it’s Enabled by using Multi-View for Android. Note: It’s True when deploying to PC]
  • Allow Static Lighting: True
  • Postprocessing->Custom Depth-Stencil Pass: Disable (to expensive)
  • Ambient Occlusion: Disable (for Real Time)
  • Ambient Occlusion Static Fraction (AO for baked lighting): True [this is the baked ambient occlusion, which is not as expensive as the real time AO]
  • Auto Exposure: Disable
  • Motion Blur: Disable
  • Lens Flares: Disable
  • Bloom: Disable
  • Separate Translucency: Disable
  • Use Splitscreen: Disable
  • Anti-Aliasing Method: For Mobile you want to have MSAA
  • Target Hardware: Mobile | Scalable 3D or 2D
  • Explicit Canvas Child ZOrder: True
  • Mobile: Default Touch Interface: None
  • Android APK Packaging: Configure Now
  • Accept SDK License
  • Minimum SDK Version: 25 or higher
  • Target SDK Version: 25 or higher
  • Support OpenGL ES3.1: True
  • Remove Oculus Signature Files from Distribution APK: True
  • ARM64: True
  • Support Dash: True
  • Compisites Depth: True
  • FFR Level: High
  • SDK Manifest: Oculus Quest
  • Android SDK Path: every path needs to target your local NVPACK installation (watch my Video Tutorial: How to install Nvidia CodeWorks)
  • Project Launcher: Advanced–> Select Quest–>Select By The Book
  • Supports Dash
  • Composited Depth
  • Splash Screen
  • Oculus Performance Window
  • Disable ALL PostProcessVolumes
  • Disable ALL Dynamic Lights (keep static lights if possible for max. preformance)
  • Mobile HDR: Disable
  • Mobile Multi View: True
  • Mobile Multi View Direct: True
  • Android SDK License: True (check license agreement and agree)
  • Android SDK Versions: Current 25
  • Oculus Mobile Device: + Oculus Quest

That’s Z-fighting, there’s two meshes that are really close together and their surfaces are ending up at the same depth and so parts of one are showing in different places.

HI that’s is just a sphere, one object the problem goes away when multiview is turned off, but would like to use it. I have multiview now off and instance stereo on and it is working but. Has anyone a solution to this should i just skip using multiview apparently its a big deal

There’s definitely two meshes there, but it might be that whatever you’re doing is reducing the depth accuracy and that’s causing it to be a problem in some cases where it’s not a problem in others.

Hi Thanks nope its one mesh, but i did open the project on another computer and the problem went away. More Vooduu of UE