Download

Multi Box Trace does not work

Hey, I want to detect everything inside the red box which responds to the given trace channel, at the moment I just use visibility.
For some reason I don’t know the multi box trace always returns “false”, and as you can see on the image below the sphere is clearly overlapping with the red box. The stone too. Both objects are set to “Block all” Collision (and of course both have a collision mesh).

w2jm387p.jpg

But unfortunately the trace does never return “true”. Am I doing anything wrong?

Any idea? At the moment I’m using “Box Overlap Actors” instead of “Multi Box Trace by Channel”, but it’s not nice because I cannot define a trace channel…

Hey John,
Are your Start and End points the same? At one time (and maybe still is this way) a trace had to travel some distance to return anything. So adding a unit or two to the Z component of the End vector may make this work.

That’s it! Thanks so much! :slight_smile:
I now try to fix this issue for 4 days and it’s so simple…
Could you also take a look at my other trace problem? https://forums.unrealengine.com/showthread.php?52270-Single-Line-Trace-somtimes-goes-through-landscape

I have a problem. The object should rotate 90 degrees after each impact. Unfortunately, that only happens on the first impact. On second impact the object no longer rotates 90 degrees.

Why necro-bump a 6+ yo thread rather than post a new question? Especially that it’s not related to the original query. [HR][/HR]

That’s because you’re setting Rotation every frame (or even more often) to be precisely that. First time this executes, you set the rotation to 90 degrees; the second and every next time you still set to the same 90 degree.

In short, you’re not rotating anything *by *90 degrees, you’re rotating it *to *90 degrees. What you want is closer to this:

Get Actor Rotation -> Combine Rotators -> Set Actor Rotation

Or, alternatively, *Add Actor World Rotation *instead.