MP4 video no longer works in 4.18 for Android

This is a known issue. We just fixed it for 4.18.2.

Should be pretty soon. Cut-off date for 4.18.2 fixes is today.

We are trying to package the project with a single video. It’s a base level with a mp4 video. It works very well with 4.17 version. We made all changes for the new frameworks. But it doesn’t work. In PC it works.

Thanks! When it will be possible to download this new version? We only see 4.18.1. Thanks in advance.

Thanks! :slight_smile:

Same problem for me.
When will be ready to download 4.18.2?

I have downloaded entire UE4 source code from github and adapted modified code which is commented above, but still the bug arises. What can I do more? Mp4 file is normal and playing in Window is OK, but On Android it does not work.

Finally 4.18.2 is here but still the same problem. New proyect in 4.18.2, third person & configured for mobile (android). New default level with only 3 planes in scene. I downloaded sample video from
link text

and follow the steps for create file media source,media player & media texture, etc and everything works perfect but when I package in ASTC and try to play it, videos are invisible but the sound is working and the most stranger thing is when I shoot the weapon from the third person and the ball (proyectile) hit where the planes would be then I see the plane in red color, no video. What can I do?

The fix or something related appears to have broken Android Mp4 streaming.

Android MP4 video streaming works in 4.17, but it broke in 4.18.

Hi, i have the same issue and i need help plase, im working in a important proyect. It is not work yet on 18.2? i cant fixed it.

I just realized that Android MP4 Streaming works in 4.17 but not 4.18.

If you are using a UMG widget to show the mediatexture, please make sure you create a Slate material to sample the media texture and assign it to the widget instead of directly using the mediatexture.

I have the same problem in 4.18.2, can’t compile for android.

Can’t compile for Android? In my case it always compiled, it’s just video playback didn’t work. You likely are just missing a dependency. You’ll want to install Nvidia Codeworks to get the compile dependencies. And then in your project settings enable Android. There wasn’t much to configure after that.

Sorry, I can compile, but the video doesn’t play on the material. Is there any other way to make the animated material to play, at least 50 frames sequence of images?

I stayed on 4.17 to get video playback working that follows the documented way to do it. That said, UE4 Staff have commented on my thread about the steps needed to make it work in 4.18. I have not verified that it works. If you can make it work, plz let me know. - UE4 4.18 - Android Streaming MediaPlayer clearing GL error: 0x500 - Mobile - Unreal Engine Forums Thanks!

Has anyone come up with a solution for this?
I tried using a material with external sampler source and UI domain instead of directly using the media texture as suggested elsewhere.
Still no video output on Android but works fine on windows. I’d hate to have to go back to 4.17 just because of this. Cheers.

I’m still having an issue with this in 4.18.3. It works with ES3.1, but not ES2.

Thank you, this fixed it for me. You may wish to update this tutorial with that step. It worked on PC, but resulted in a black screen on Android before I made this change.

I have the problem now for 4.22 for Oculus Quest. It’s really Super annoying. What formats are known to work on Android?