Download

MP4 to SWF? (and weird things )

I hope someone reads all of this as im not sure if its possible or not.(im going to leave Bink and scaleform out of this )

‘‘I really want to know if its possible to have a video(doesn’t matter the format) import it in to Adobe flash and convert it to SWF and play it in udk with the Open GFX Movie kismet node?’’

I read the archived udk forums and what few comments ive found is that only licensed ue3 can play flash video? Can anyone confirm?

Here is what I did.
1-Took a 25 sec video from youtube for a test.Imported in to flash.
2-Set the publish settings to Flash player 8 and Action scrit 2.0.(also tried with settings of Flash player 11 and Action script 3.0)
3-Export as a SWF movie.
4-If i click it in windows it works, but in UDK id doesn’t play at all.I use the Open GFX Movie kismet.

Is it meant to do that or did I do something wrong?

I… i did something else…
1-Placed the original MP4 video in the VLC player and from there exported the video in frame by frame images.A total of 785 png images each at 1280x720.
2-Imported all the images in to flash and from there exported as a SWF video again.Final file was like 68 mb swf video.
3-Imported that SWF in to udk and it created a SWF movie and also dumped inside the folder all those hundreds of images.From a original 68mb swf file in windows, I ended with a 400+ mb upk.(ohhh boy)
4-Pluged the thing in to the Open GFX Movie kismet and it works(no sound for some reason?) .
5-Also noticed in Stat memory in a empty level with the video playing, a Texture Memory used of more than 450 mb.Even when the video ends and I end it with the Close GFX movie kismet and delete everything and start a blank level, udk still reports those Texture Memory used of more than 450 mb in a empty level.So a memory leak or the ram just doesn’t want to clear this?? I have to restart udk in order to fix this.
To be honest, even if i fully load the package of the video without importing it in to a scene, that triggers udk to eat that texture memory without even importing the video.

If someone has the time to look at all those questions and events loud be super helpful.I want to know if what i did was bad or fine or if its just a udk limitation.
Cheers to everyone!!

1 Like

Hello mate. Sorry for the delay to answer you. Unfortunatelly the scaleform version which comes with UDK does not support video. Doing what you have done is not the best way. I have done it for my game’s main menu, the 3d character idle animation, but it were just 30 frames of animations. The only way to have video on UDK is indeed using bink video, unfortunatelly.

1 Like

Thanks dude.At least I know its a udk thing.WIll have to settle for bink than(note to others reading this>there seems to be a framerate drop if using bink in dx11.No idea why.Ive experienced it in play on pc .Haven’t tried a final cooked game but be aware.)
So in your moded udk you are with the same options for what I was doing? For the video feature we need full UE3 and a scaleform license that probably adds extra kismet nods for that feature?(not that they sell them anymore xd)

You can make custom Kismet nodes without a UE3 license. What do you want to do with the video that you think you would need a full UE3 license for? And also, the UE3 license does not include a bunch of the licenses that UDK has. Specifically, UE3 does not have Bink. You would have to get a Bink license and integrate Bink on your own.