Moving Actors with InstancedStaticMeshes leaves collision behind

Hello! I’d like to report a bug. When moving, scaling, or rotating an actor that uses instances mesh components, the component’s collision is left behind. But when using regular static meshes, the collision follows the actor. It would be great if this could be fixed before 4.8 releases. :slight_smile:

Hi KoldKam,

This is a known issue that is currently under assessment as UE-13673. It is marked as major but has no resolution as of yet. Unfortunately I do not have a timeframe of when this will be fixed.

I think I have never seen a “major” bug taking so long time to get fixed :frowning:

Right before to transform some actor which used ISMC, use the node “Set Collision Enabled”->“No Collision” and right after transforming restore the collision with the node “Set Collision Enabled”->“Query Only”