Download

Movie Render Sequencer Not Rendering AVI

Hey ya’ll,

Really needing some help. I’ve been working on a short film on UE 4.26.2. I’ve been at it for several weeks, rendering my clips fine until recently my sequencer freezes when I render a scene. It renders one frame then freezes and UE 4 stops responding.

The thing is, I’ve tried other projects and it exports without a hitch. It’s only on this project. That and I can play the game as normal. When I hit export as XML it exports but it doesn’t leave any files. I’ve tried exporting a level with nothing from the same project and it suffers the same thing as if I rendered an actual shot from the film.

I’ve checked all around the forums, hidden actors, set lighting to their default, messed and disabled my post-process volumes, but nothing is working. It’s been frustrating because I’ve got two minutes complete already by doing this process and just now it’s not working.

Hopefully, someone could help!

Wow, here I am, 9 minutes later, and I figured it out. So it turns out, in my naming convention, I had somehow entered a semi-colon in front of the file name, that’s what was causing the issue.

THERE GOES 9 HOURS OF TROUBLESHOOTING…

I guess it makes sense, though?

AHHHH!!! Normally, i’d be really mad considering how much time i spent on this, but all I could do was laugh manically. (and almost cry)

1 Like

I wish Unreal devs would put in a bit more defensive programming to stop simple user issues. They should filter or alert if user input isn’t working rather than lettign low level code stumble and crash.

Another common one is the Movie Render Queue never checks validity of the file path. It will render each frame, discover it can’t save it and add a log message and then happily run for hours over thousand frames without alerting the user. A simple check at the very start and an alert would have solved that.