Movie Render Pipeline Temporal Sample Count Error Message in 4.27.1

Hey there,

There was a Camera Shutter Angle setting in Movie Render Queue setting back in older version, but it’s gone now. A post on Answer Hub mention that motion blur amount value 0-1 is now mapping to 0-360 for shutter angle. Motion blur amount in my scene is set to 0.5, so I guess it means 180 shutter angle, but I kept getting error while trying to bump up Termporal Sample Count.

MoviePipelinePIEExecutor: Error: Too many temporal samples for the given shutter angle/tick rate combination. Temporal Samples: 2 Shutter Angle: 0.500000 TicksPerOutputFrame: Frame: 1 Subframe: 0.000000 TicksPerSample: Frame: 0 Subframe: 0.250000. Consider converting to Spatial Samples instead!

Anyone knows how to properly sets up temporal sample counts for motion blur in UE4.27.1??

3 Likes

Answering this awhile after posted because I had the same issue and fixed it.

I was having this issue because in my Level Sequence the tick interval had been set to 24fps by an importer tool. Default when you create a new level sequence is 24000fps so that Temporal samples, frame rate changes etc can be calculated.
This is set in the Level sequence by clicking on the fps drop down and going to advanced options and changing the Desired Tick Interval to 24000fps or whatever works best for your level sequence.
If you’re setting it in BP, Get Current Level Sequence and then Set Tick Resolution and put 24000 for example in the Tick Resolution Numerator.

2 Likes

Did you ever manage to fix this issue?

Issue is still relevant.
UPDATE: Managed to fix it by setting in post process volume motion blur amount to 0.5 (default value).

1 Like