Movie playing on a Widget just displays a black screen

So I just upgraded to 4.18 from a much older version of the engine, back when Widgets were considered “experimental”.

Right now I’m trying to figure out a problem where the intro video I have isn’t playing, just displaying a black screen. The video is played by adding a widget to the Viewport and then having the widget do Open Source on the movie I want to play. As of now I have stepped through every step and everything is supposedly working correctly, except the video playback.

The video itself isn’t the problem because I tried opening the uasset in UE4’s native video player, and it played fine.


I have since attempted to simply test the media player by adding video to a blank level, with a new actor, new widget, and a brand new mp4 that I imported into Unreal. I’ve tried both playing it on the widget, and testing by dragging the media player’s texture onto a plane.

It seems that Media playback does not at all, in any way, under any circumstances. Currently I’m using 4.18.1

I ran into a similar problem after upgrading from 4.17 to 4.18 where my old media textures didn’t work in UMG; ones made after the upgrade worked. I found that if I just made a new media texture and pointed it at my media player it started working again. Not sure if that’s a solution for you since your comment implies that even new files are broken but possibly worth a try.

Did you remember to set the texture to external? I had a similar issue when updating from 4.16 to 4.18, turns out that I simply forgot to update my simpler type on the video material.