Download

Movement not working when physics enabled

hey, new and learning UE4, as the title says I am having problems with my character, it’s a 2D paper character and movement was working fine with WASD however as soon as i turned on physics it stopped working, I turned on physics cause I am making a 3D world but I suck at drawing and animation so making the characters 2D. Can anyone help as to why this might be? as I said it works fine without physics so I think it is somewhere in my speed or friction settings.

movement blueprint.png

blueprint1.png

blueprint2.png

BUMP. still a problem, can anyone help please?

BUMP again, anyone have any suggestions?

in character movement, gravity default value is set to 1, so i dont understand the path u said when u turn on gravity.

with it off it does work, but on, like it is now, it doesn’t work. gravity doesn’t work with physics turned off for some reason

BUMP! again, any suggestions?

Character movment is not intended for physics based objects that I know of. Turning in physics you are essentially turning off character movement no?

well do you know why gravity turns off once I touch the ground?

I spawn my player high up, i watch him fall, then he hits the ground and moves around, goes up a ramp, I don’t go down the ramp, just float off it

How us the player moving? Are they set to character movement flying?

I’ve never set anything besides movement in input maps so not sure where I would have set that. I dont even use crouch, jump, run, swim etc, I adjust walking speed myself

Is the collision in the ramp making a box and they’re walking on it.

Would have to see more to figure out what’s going on. The ramp and the components on the player

definitly not, they walk up the ramp fine, just don’t come back down. ill take some screenies after work

@statphantom:

I recreated your settings and the player is fine. But just a hint. Can you maybe try to set your “mass” in the character movement component to something other than 0? Maybe 100 or 200 or something higher?

mass set to 80 originally, set it to 0 when I was messing with the settings, changed it again and the same problem occurs, just float off ramps, don’t move back down at all

I think you’re right, when I angled the camera I saw a gap between me and the ground. the collision looks like this.

cdf47df31a69cd58117115d33b766aed734d69c4.jpeg

is the collision the purple not the blue? if so, how do I made it the blue?

Not at my computer but this might be overal useful to know

https://youtu.be/XLvJnFUk3Cc