Movement Logic Broke Down

I working on a side scroller and it was working correctly. I add new animations to the blendspace than whole movement logic broke down.
First my Input setting had changed. I re-set the axis mapping. Than tested keyboard input works.
In Blendspace i test with “greenpoint” it is working to.
I upload some nodes, everyhing is working it seems.
max walk speed 600
When i debug in blueprint there is correct flow until add movement input node.

But my character doesnt move right-left. Velecity is 0. but keyboard sends “1/-1” to the add movement input node.

I cant understand what is going on please help
thank you

This is getting wierd because i changed the ıdle/walk/sprint animations into the base Mannequin animations, it worked. I made logic for testing, press T play animation (i put the broken animations) and they also worked.
When i implement the new animations to the blend space, animation is not working and character doesnt moving (this is wierd), but when i use the mannequins animations it is working.

Hello! Just remember - for default character all movements are in Character BP, all Anims are in Anim BP. As for movement: after you have updated input axes in Input settings then input events in your Character BP may become broken…

Hello, i found the issue. My animset contains some root motion animations. So blendspace doesnt play animation if the AnimBP dafault setting is set to ignore root motion for animations. So i solved my issue thanks me

Good luck!

Thank you mate