Moved to 4.9, duplicating blueprints from 4.8.3 create BAD blueprint

A few of my blueprints has been broken in some way during the upgrading the project to 4.9 (from 4.8.3), so i decided to test duplicating the blueprints and seeing if the duplicate would work…

to my surprise EVERY SINGLE DUPLICATE makes a blueprint that wont compile, lost all the components and simply displays a sprite that says BAD BLUEPRINT

Do i have to manually rebuild every blueprint now??? or is there some simple way to fix this?

Hi ,

I’m a bit confused. What specific steps are you taking to convert your meshes over? Are you just passing them into the new project or do you have any steps I can take to reproduce this on my end?

No converting of meshes at all.

In Windows explorer, I have a folder, in there I have my Game.uproject I right click on it change version from 4.8 to 4.9.

Then once I’ve opened the project, if I were to right click on any blueprint and select duplicate, the resulting duplicate would be a BAD BLUEPRINT. All of its scene components would be gone and it will not compile.

I have two different instances that if I were to delete nodes in the blueprint before trying to duplicating it creates non bad blueprints:

Deleting all timelines before duplicating
Deleting all variables of type (arrays of actors) before duplicating.

What happens if you take your project and create a copy from the launcher? For instance, if you open the launcher in 4.9 to open the project selection and select your 4.8 project, then press “Create a copy”, do you see the same errors occur?

yep, exact same issues.

but if i delete the timeline nodes it duplicates fine… i think that classifies as a reproducable bug.

im gonna test this by making a new project in 4.8.3 and changing version to 4.9 and see if thats exactly whats breaking it.

also now i cant package the project for. but thats different problem so ill post that elsewhere.

k reproducable bug.

make a blank project in 4.8

make one blueprint, that has a sphere component, make a timeline node, make the timeline have a float track that has any animation (i had t0v0 t0.5v1 t1v0) make the timeline on update go to the sphere components relative location make the relative locations z set to the float coming out of the timeline.

once this is all done, duplicate the project and change version to 4.9 manually or do it via the epic launcher.

open the project, duplicate the blueprint, leave its name, and then open it. youll see it has broken all the scene components.

interesting extra test…

if the exec pin coming out of the timelines update pin doesnt in any way affect the scene component then duplicating it wont cause a bad duplicate.

Yeah, I can vouch for this. I’ve had issues with timelines within my game after upgrading from 4.7.6 to 4.9.1. My work around is to manually recreate timelines without using the timeline node (using curves and blueprint logic).

HI everyone,

I attempted to reproduce this on my end, however the timelines I have created seem to convert without error. Can you post a screenshot of what you are doing with the timelines or send me an asset that I’d be able to test with on my end? I’ll be happy to take a look.

Hi ,

We have not heard from you in several days. I am marking this thread as answered for tracking purposes. If you are still experiencing this error, please comment back with the requested information.

Experiencing the same thing. Duplicating a certain BP doesn’t duplicate the components, so properties in the BP associated with those references are broken, causing compile errors.

I think it was working yesterday, before I upgraded to 4.9.2.
Test case:

  1. Create ContentExamples project
  2. Duplicate BP_Spline_Location
  3. Open duplicate. Spline/particle components are missing, causing compile errors.
  4. Duplicate BP_Spline_Mesh. No problems.

Not sure why.

Hi aoakenofArchiact,

The compile warnings you are seeing in the BP_Spline_Location blueprint, do they say this?

“Warning Get World Location at Distance Along Spline is deprecated; Please use GetLocationAtDistanceAlongSpline, specifying SplineCoordinateSpace::World”?

These nodes are depreciated, I’ve entered a bug report, UE-21700, to be assessed by the development staff.

If this is not the case, I have not been able to reproduce this on my end. Do any other blueprints cause the same problems for you that I can take a look at?

Hi ,

I experienced this issue in 4.9, 4.9.1 and 4.9.2 (4.9 projects and some 4.8 projects converted to 4.9 too)
This Happen randomly , in Content browser I duplicate a certain “Actor BP” , but it won’t compile because all the node are duplicated correctly but all the component attached to the actor are gone

Hi ,

Is this limited to one BP or is it any BP you duplicate? What nodes are you using inside of the blueprint? What warnings, if any, are given?


I’m having the same problem, when duplicating a blueprint I don’t get any of the components, however this used to work until I updated and duplicated my project.
I assume this is related to the warning I get every time I save:

This map is using externally referenced packages which won’t be found when in a game and all references will be broken. Perform a map check for more details.

How can fix this references? do I have to move files to the local folder, then where and what files?

Right click the Contents folder in your content browser and press “Fix up redirectors”. Does this fix the errors? Are you using 4.9? When did these errors appear? Are your blueprints that are showing this error duplicates or are they individual blueprints that have been manually created?

Hey arnoldo,

Try this to find what is actually breaking it.

First… save your project somewhere else so we don’t mess it up.

Second…Before duplicating the original blueprint, go into the original and then delete huge sections of code and then go back out and duplicate the blueprint. Do this multiple times until the duplicate actually opens correctly.

I know it sounds crazy but eventually you will delete the section that causes the duplication error.

When I did my delete section duplicate over and over my 5th duplicate was fine and it’s components were all there.

I would suggest deleting any timelines and then duplicate and see if that fixes it. After that I’ve found problems with custom structs and enum switches.

Maybe if someone else can verify its timelines it will get added to the bug list.

Good luck. :slight_smile:


, Thanks!

I tried deleting the timelines and it worked out, so this is officially a bug.

to reproduce: I created a fairly large blueprint actor including a couple of timelines and when duplicating all the components disappear in the duplicated version.


Fix the redirections doesn’t seem to do much, I’m still getting the errors, I’m using 4.9 (Version: 4.9.1-2689999+++depot+UE4-Releases+4.9); these errors pop up overtime I hit “save all”.


Do you have a blueprint sample I can attempt to reproduce with? I have yet to be able to reproduce this on my end. Any additional information would be greatly appreciated.

yes, I did the test with a new blueprint containing a sphere and a cube as components and a timeline in the event graph, when duplicated it loses the components (cube and sphere).
link text

If you duplicate the BP file from finder works just fine.