Download

Move Up help

I created an input for moving up and down in the First Person example, it doesn’t work, I’ve tried toggling gravity on and off but pressing q+e does nothing at all.

Can someone give me a hand.

Thanks.

468ba03fb7800e6784659d02c750d84640db63d6.png
575e200770825a5aeb995f205b02df1e6d152b6d.png

Hi derezzed,

I know exactly your problem. I went a little crazy trying to figure it out. You have to switch “default land movement mode” to Flying under your characters blueprint. Just type default land move… in the search field to find it. There’s a video of my project with this enabled.

cc638fc0c3e96a969dabda24391ce3d80579b977.jpeg

Some other links
https://forums.unrealengine.com/showthread.php?6759-Simple-Side-Scroller-Game&highlight=simple+side+scroller

Excellent, thank you!

Worked a treat.

Glad I could help!

So, the problem I have now is, I can move up, down, left right etc - but I wanted to add the ability to roll to the left and right.

I’ve done this using Add Controller Roll Input.

When i roll my character it stops rolling after 90degrees.

When my character is rolled and I try and move in a direction it moves the character to the world left instead of the local left of that character.

Hope that makes sense.

Screen Shot 2014-06-11 at 12.31.04.png

bumping to the top :slight_smile:

Anyone?

I don’t know why it is so, but when you roll the character as per your input node, the rotation of the actor doesn’t change, the rotation vector is still 0.0.0.

I don’t really have time to look for a solution right now, but the “get actor right vector” gives you the correct vector… the actor that isn’t rotated(this is also the reason that you cannot rotate more than 90 degrees). You need to rotate the actor itself, not just the controller input.

Does this make sense?

And I found this:
https://answers.unrealengine.com/questions/4312/question-set-actor-rotation-vs-set-control-rotatio.html

Yeah, makes sense, I’ll try it later and see how I go, cheers.

How to reduce inertion when “default land movement mode” set up as flying?