Download

Move and Rotate Sequencer

Hello folks, anyone knows how to use new feature in 4.19 called (Level sequence dynamic transform origin. ) ?

There’s properties on the Level Sequence Actor that allow you to set the origin that all the sequencer transform tracks will be relative to. You can set the origin in the details panel or you can also attach it to an actor in the scene or set it in blueprints.

Keep in mind, only objects that have transform tracks in Sequencer will be relative to this origin.

Sequencer_DynamicTransformOrigin.jpg

I can’t seem to find the way to do this in blueprint. Is there a something special that needs to be done, or is it not exposed?

It’s not exposed at the moment. We recently added the ability to do this and it will be available for 4.20. If you need it sooner and can compile from source, the CL is 3983812.

Here’s what it will look like:

Thank you so much for the response!

Hello,
I’m trying the new 4.19 “Level Sequence Dynamic Transform Origin” feature, but I have no success. I selected an actor as Transform Origin Actor, but the sequence content does not translate with it. I looked at the code, and saw that the function call “Player.GetInstanceData()” in “FMovieSceneComponentTransformSectionTemplate::Initialize” returns a null pointer (coming from “PlaybackSettings.InstanceData” in UMovieSceneSequencePlayer). Am I missing something?

Thanks for your help,
Marco - Milestone s.r.l.

Any updates on this? Will this feature be on 4.20 as mentioned? I am asking because I want to make an sequence relative to a certain actor. For example I want to create a sequence which plays an “open door” sequence and which will be relative to the door which I want to spawn multiple times in the level.

best regards

Now that 4.20 is live, I was testing this again. I was able to move the origin, but the animation still plays at the original origin(0,0,0). I’m not sure if there’s something that I’m missing. I do have the actors in the sequence transforms set as absolute. I’ve tried both using a origin actor and setting the transform directly, neither seems to move the actual sequence. I’d love to know what I’m missing(I’m sure its something stupid!).

Here’s what I have working 4.20. My sequence has a skeletal animation and a transform section (absolute). When playing the sequence, the skeletal animation pops to the location of the cube in my level.

Hi Im not sure if this is the right spot for this i have an animation issue when i move my character he move like he should whit no weapons but the head is always looking in one direction like hes locked onto something even when aiming. any ideas??? i am using the MP_SK Project … with the survival game kit Project migrated into the MP_SK project i also used the migration tutorial from the survival game template

After some more button pressing and not turning, It looks like my problem is I didn’t have the override instance data flag checked.

It doesn’t look like that is exposed to blueprint. So I’m not sure there’s anyway to set it if I spawn the sequence into the scene at run time.

Hey I’m on 4.20.1 and have the same issue as mfg65. The whole thing just plain doesn’t work, even when I just statically set everything using the actor details. Everything in the sequence is still just located at absolute 0,0,0.

Hello there,

is it possible to achieve this behaviour with Spawnable Actors? I have the situation, that I want to play the same moving/rotating bevhaiour in arbritrary scenes or atleast spawn the Actors on defined positions in different levels. If I pick a Spawnable Actor from the Sequencer into the Instance Data it gets simply removed after saving or PiE. But maybe I’m just doing something wrong here. I’m pretty new to the sequencer. At the moment I’m considering to spawn Actors without the Sequencer and add the binding afterwards.

Update: I managed it now by using a Camera Rig Rail for the Actor’s movement, and the Rail can be placed, after it was spawned by the Sequence (unlike Actors themselves)

I’m having trouble getting this to work. Is there some trick to it? I have a preexisting level sequence animation on an object. I want to be able to move my entire level. So I added an Empty Actor at 0,0,0, and made that the Transform Origin Actor. If I then move that actor, however, the animation does not move. Also, if I move the entire level, the animation does not move with the actors the way I would expect. How do you get this work?

I also tried following these instructions, and they did not work. Is this feature broken or changed somehow?

It looks like what you’re missing is enabling the instance override as well on the level sequence actor:
ue4_enable_instance_override.png
Hope this helps :slight_smile: