.Mov no longer supported in media player?

Just installed ver 4.13.0 from 4.12.5 and everything works perfectly for me except for one thing - why are my .mov textures not working any more? they are no longer in the asset drop down import list! is there a different way to load them in or something? I can import a .mov but I can’t turn it into a media texture and in turn apply to a material…

Hey THINKTANK,

So this is actually not a bug as we have overhauled the Media Player framework for 4.13, and the process of going about calling your Media Source files to play has changed. Take a look at the posts below to get an understanding of how to go about setting this up on your end.

These sources should get you to a working point, but if you have further questions please let me know. We are in the process of updating our documentation to reflect the changes made to the Media Framework.

Cheers,

Andrew Hurley

Thanks Andrew although I don’t get it! couple of things first off:

  1. I have copied my media files into the media folder in content, I then import them to Unreal and then I still need to change the link?

  2. How do it turn it into a media player file? I create one but I can’t see an option to load the media source file

  3. before I needed to set the Play rate in a PB in my main level fine, but now I need to add more bits in order to get a media player file working?

Ok so managed to get the media player to load my .mov file, then create a texture from it (altho cant see any preview in the texture but any whooo, now i’ve updated my material and I can see it in preview until I hit play then it all goes black and back to square one. I dont understand why i have to create 3 elements to get a video to just play!

I’m also getting a “current material has compilation errors, so it will not render correctly in feature level SM5” whats that for?! everything was working in 12.5 I only got the new version as I wanted to start using the VR template…might go back and wait for this to get fixed (or is it me?!)

Ok so managed to get the media player to load my .mov file, then create a texture from it (altho cant see any preview in the texture but any whooo, now i’ve updated my material and I can see it in preview until I hit play then it all goes black and back to square one.

Could you show me a screenshot of how you are calling the Media Player to playback your media source files within blueprints?

Could you also show me the material graph you are reporting the compile issues?

I dont understand why i have to create 3 elements to get a video to just play!

This is simply the new process we have implemented. You have your media source files which need to point to the copy of your media file within your Unreal Projects > YourProjectName > Content > Movies folder.

The Media Player is what holds any number of media source files where you can create a playlists and control the playback.

The Media Textures are what you use to create the material and the media sound waves are what is used to implement the sound for the associated media source files. We have only technically added one additional element to this process which is the Media Player itself. We separated this from the actual media source files so you can specify the file path and the codec/player used to playback the video file.

Please take a look over the two posts I linked as they will give you the correct solutions to setting up this process correctly.

Thanks,

Andrew Hurley

Hi Andrew, ok so I have got it all to work, however my preview whilst in the editor still shows up blank until I ~“play”. please see screenshots to show you how I have set it up. Let me know if this is wrong (I’m guessing it is?)

My button that is using the video is a rectangle, with a material on the object. when mouse overlaps it changes material to a different video (and off again once overlap is finished) the buttons exist as soon as level starts.

So my main two problems since 4.13 is that I no longer get previews in view port and for a split second when running Play the textures go black before loading. is there a way to fix both? thank you for your time.

Level Blue print -

Media Source

Media Player

Material

So in short, the Media Player can be looked at as the framework or tool in which to play your Media Source files. These Media Source files need to be called to ‘Open’ in order to preview them within your Media Player itself.

In your case, all you should have to do is right-click and open the Media Source in question that you wish to preview, and since you have the ‘Play on Open’ option checked, it should automatically play in your Texture Sample preview.

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

Ok thats fine but what I am on about is that before I used to be able to in real time see all my textures in the editor, now I dont see them until run time. I like to be able to see everything how it would in the game in the editor where possible. am I missing a check button that makes it all visible in editor?

Current preview in editor:

Preview I used to get in 4.12

Worth noting it does in fact preview in 4.13 but I have to keep the media player open and playing on the selected video, before in 4.25 I didn’t have to do this

This behavior has changed and it is expected. In regards to your original issue of .mov not being supported, we added settings to increase copatibility with the Media Framework.

Navigate to the Project Settings > WMF Media

Project Settings - WMF Media

Thanks,

Andrew Hurley