Mouse over event not working

simple as described, am i missing something ?

can anyone help?

Hey -

Depending on how your blueprint is setup you’ll need to include a set node for “Enable Mouse Over Events.” You can access this node by adding a “Get Player Controller” node and dragging off of the return value pin. This will allow the mouse to register when it is overlapping with another actor.


yeah, im not sure what im doing wrong, i have the enable mouse events in the player controller, ive even done this in the BP where i get player number and then enable aswell, it does nothing, however the content examples mouse over works, ive added collisions to the mesh, ive set it to blockalldynamic like the content examples… what am i missing ?

thanks man

The screenshot below is used to control lifting an actor off the ground as long as the mouse is over the object and the left mouse button is held down. The top right section (Show mouse in game…) can be defined inside the player controller like you have, but you should be able to use a similar setup inside the actor blueprint to control mouse over events.


im having a bit of trouble still, but il have a tinker around and see if i can get it to work some more
thanks man

nop, if you click - it counts as mouse over. if you mouse over - it’s ignored

on the Add to Veiwport, change the z order, by clicking the dropdown arrow on the bottom of the function, to 1.

yeah, but that applies only to widgets, not to meshes (actors )

This is still a bug in 4.25.4 unfortunately.

This could be a problem with collision.

  1. Open actor BP for actor you want to interact with
  2. Select the mesh you want to interact with
  3. Under ‘Collision’ set Collision Preset to ‘Custom’
  4. In ‘Trace Responses’ set ‘Visibility’ to Block.

If you just want your actor to collide with everything you could just set Collision to block all dynamic, but that may not work for your desired application. Once collision is set to block on the visibility channel your mouse over events should fire correctly within the blueprint.

1 Like

Hi All, I still see the same issue in UE 4.27
I have a Master Actor with Collision settings to Block VIsibility and 2 child actors with no changes but different static mesh. 1 Actor responses to event Mouse Over, another one doesn’t.
If I spawn any other actor to the game, 0 actors getting event Mouse over until I click on them.
Any ideas about this?