Download

Mouse events not working from BP

hey, this is my game so far:

When I create a mouse-related events through the player controller everything works well,
But when I create the same events through the BP from kind Pawn the event does not execute
Where’s my problem :frowning:

Hi,

Show your blueprints so we can see what’s the problem

so this is my BP (it’s not working from this BP):
bbf417eccb6a465cff2eee2b5db9a2e2b421bc38.png
this is my playerController:


this is my gameMode:
e5a65506d8576b15996278adeea0e03609bf19a4.png
and this is the result:

you can see it’s not execute the left mouse click from the BP…

You should setup your code on your player controller as this controller has been setup in the game mode. In the raw blueprint, it does not know what to do.

In your Tank1 blueprint look under “Input” and make sure it is set to auto receive input from your player:

d125d152506cf6a2940c6c50f132fea3aab263cf.png

Thanks Mosel3y. It’s true they say that by helping you are becoming better and better :smiley: I always keep all my char’s stuff in the player controller and use blueprint actors with code that references to them and did not think the obvious answer of yours :smiley:

I changed it but it still does not work

Did not really understand what I need to do or how …

If you click on the Left Mouse Button events, make sure neither events have “Consume Input” checked

Indeed, this one is easy to overlook :slight_smile:

it was checked :frowning:

Sorry, I meant to say unchecked

LOL, I also tried it…
Wait, in the BP(tank1) or the playerController??? well I tried both of them…
You might know where I can get an a example project with mouse events?

Have you set Auto Possess Player in the details of your tank, to player 0?

But yes, if you actually want Left Mouse Button events in two separate actors, you will need to have Consume Input unchecked on the playercontroller

you can enable input as desribed here: https://docs.unrealengine.com/latest/INT/Gameplay/HowTo/ActorInput/Blueprints/index.html

all this doesn’t help