Download

Mouse does not hide automatically when I set show mouse cursor false.

Hey guys, I’m having a issue where I set show mouse cursor to false in the player controller blueprint. however, when the function is called (and it is called), the mouse cursor does not get removed immediately. instead I have to move the mouse 1 pixel to get it to hide. Any idea what might be causing this? Happens in PIE and in Fullscreen.

Context: This is my player controller BP. It has its ANY KEY details set to (Consume Input (False), Execute when Paused (True), Override Parent Binding (False), With no other modifiers.) The purpose of it is to rapidly swap from controller input UI windows, to Keyboard UI windows, and back at will of the player. But what happens is, press left mouse, cursor shows up. Then Press “A” on controller, Cursor stays up until you move the mouse. once you move the mouse, the cursor goes away. I want the cursor gone the second I press “A”. Any ideas on why this is happening? Even though it says it hid the cursor when I tied a print string on the back of it?

I’m having the exact same problem. My blueprint looks almost identical to yours but unfortunately I have not found a solution yet.

@Nightlocke I was able to find a solution/workaround: SetInputMode. Options are GameOnly, Game and UI, and UI Only. Since I currently do not have interactive widgets when my character is moving around, I found that SetInputMode GameAndUI worked well with my mouse and keyboard mode, and GameOnly worked well with my Gamepad mode. Going forward I think I will have to pay close attention to which input mode is being used when I add more UI elements.

Here’s how it looks in my project: