Mouse axis input not working in packaged game

If I create a new project based on the FPS template, everything works fine in the editor.- Also when setting play options to “standalone game” or even launching the game for Windows the mouse input works. If I package the game though, any movement on the mouse axis is ignored (LMB shooting still works, so the mouse is recognized only the xy movement isn’t)

I have seen similar question being asked several times, but none of the solutions works for me.

Any help would be much appreciated!

You need to copy the config folder from your project to the new FPS project.

unfortunately that did not fix it here…


My recipie is:

  1. Migrate maps

  2. Migrate characters

  3. Copy config and movies

  4. Update main map in new project.

It has to not be open in the editor for all of this…

Instead of copying all elements, I just created a totally new project based on the fps template, without applying any modifications and packaged it.

Thanks to your tip with the config folder, I now packaged the game without .pak files. This way the DefaultIInput.ini was created and I was able to modify it. I verified it working by setting bF11TogglesFullscreen to False and it worked. Unfortunately the mouse axis issue still persists:

I tried different settings for DefaultViewportMouseCaptureMode and DefaultViewportMouseLockMode, but without luck.

I’m at a bit of a loss actually. Do you have unusual code on that axis? Are you doing something different there?

Try using node Set Input Game Mode Only at event begin play