MotionController doesn't show events options

Hi, i’m new programming in oculus projects and i can’t find the option, and i don’t know how to fix it.

I’ll be glad if someone can help me.

Have you enabled the plugin and restarted engine?

Anyway you can do same a lil bit different (and intended) way

Go to Project Settings, Mappings and there Action/Axis Mappings are your friend

You give them a name, assign buttons and ‘summon’ to a blueprint

Axis - for triggers/sticks
Action - for press/release

Hi, thanks for answering me, but still doesn’t work

Unfortunately I have only HTC Vive so I cannot tell or really test

Does this happen on a fresh new Project as well?

yes, i tried uninstal everything and instal again like 5-6 times, but doesn’t work, my last option was find and onption here, but it’s really hard, but thanks to try.

1 Like

Change the Title of your post and add something like “seeking EPIC support”

It’s not a normal behaviour - you have everything enabled and also reinstalled, the binds should be findable on right click (besides if you’re f.ex. in the Widget BP where it’s simply not available)

Also the binds can be found in Project Settings but they trigger no events at all

I assume you have no issues when playing games with your controllers recognition, right?

playing, no. I’ve 4 programs to finish, the problem is just programming MotionController Buttons and triggers.

But having a designed Plugin for that should make it functioning as intended :thinking:

There are external Apps to create a DLL with the inputs but that’s not the same as the Plugin you have built-in to the Engine and won’t give you any big benefits for an Engine, only for games/apps

That’s the point, my VR projects needs the unreal benefits.

You can issue this as a bug to Epic Games using their form to submit your issue

thanks, really

1 Like