Download

Motion Builder retargetting Kinnect MoCap data question/problem

Hey folks,

I have no idea if anyone can help me on this matter…
But I bought myself a Kinnect for MoCap, and having been using the Brekel Pro Body software to record then import into Motionbuilder.
I’ve been trying to remap the MoCap data onto the TPS skeleton/Model from UE4 with NO such luck…
My problem is whenever I merge the MoCap with the model/character I CAN NOT change what Input Type it is… (Active or Not Active)

I Click the drop down box and if I try to change to Actor, it acts as if that’s not an option and will not highlight it.
I CAN however, choose “Control Rig, Current Skeleton and Stance” from the list…
If I try to choose “Character or Actor” nothing happens and it defaults back to “Stance”
Anyone have this problem before and know how to fix it?
Thanks
232d3f6e19e83e22c256fc21652f51be0be04f5a.jpeg

You will need to characterize both the target and source to transfer the motion from a different set of naming conventions to the naming convention of the target rig.

The work flow would be to characterize your target (Rocket-Blueman-UE4-t-Pose) and merge the t-pose file for the Kinnect rig. With the root of the Kinnect rig selected you can then import all of the clips made using the naming convention for that rig and plot all takes to the Character rig and set it’s input to, probably, Character1.

With UE4_Tpose selected you can then set it’s input to Character1 and the rig will snap into position of the Kinnect Character, plot all takes to the target, and once done set input to Character (or what ever you name it).

Once done you can then delete the input character, plot all of the UE4_Tpose takes down to the skeleton and export to UE4 and should work with the default UE4 rig

You sir, have made my day! lol
Thanks FrankieV, in all the documentation I have read, NEVER did I read that the MoCap would need to be characterized…
I haven’t been able to get the completed animations to work properly in UE4 on the first few tries… but at least the Character is taking the MoCap data now!
Just to figure out how to import it properly, I’m sure there’s something I’m missing, just too tired to figure it out right now lol

Well getting the animation to re-target is just half the job if you don’t have a 1-1 match as to the scale difference between the two rigs (Action Space Compensation) Due to maybe the lack of a 100% tposed character.

To get a better match you can play with the IK TR and pull as well as the Action Space compensation mode in the Character Settings.